Move/Rotate aren't working

So basically I’ve been trying to work more on the physical aspects of my game recently, but for some reason it’s not letting me move or rotate anything. I thought it was just my mouse at first, but even my touchpad won’t work. (and my touchpad usually doesn’t glitch) I think it might be a problem with the studio, but I don’t know how to fix it. I closed and re-opened everything, but it’s still a problem. I can only move objects when I drag them around without using the move tool, but that’s a really inefficient way to do things.

robloxapp-20201129-1702214.wmv (849.2 KB)

Edit: I tried reinstalling roblox studio, but nothing happened.

Have you made sure that the pieces you are attempting to move are not “locked”?

This sounds like a simple and dumb fix but most problems usually are.

It’s happening with everything, not just specific parts. I’ve also tried the unlock all button, just in case, but it isn’t making a difference

Are you using a plug-in such as F3X or are you using studios native tools?

Just the basic studio tools. It seems to be working about half of the time now, but it still isn’t functioning properly

Have you been working with any free models that could have injected “viruses” into your individual parts?

I know a few years ago these would cause chaotic responses if spread to the game.

I have been using a few on a different game (a small thing for a project). Would those spread viruses into the entire studio?

No and they are real viruses just LUA scripts that interfere with your individual parts functionality.

I’d just look at your models and make sure there aren’t unwanted scripts in there

Ok, but this is happening even with parts I just created from the “model” tab, which shouldn’t have scripts

What I would suggest is, reinstall Roblox Studio.
This maybe a bug from Roblox’s side.

I would also recommend to run an Anti-Virus software test on your device in such circumstances.

There has been threads related to “can’t move objects”. Turn constraints off to prevent this from happening. It may be because you have toggle that option, to prevent this you need to toggle this off to unlock the part. In the toolbar untoggle constraints if that doesn’t solve your issue, can you please show your toolbars: