Moveto() Just doesn't Work

I’ve tried to use the Moveto() command to try to get a humanoid to move, but so far nothing works. Here’s the small line of code I used.

script.Parent.Humanoid:MoveTo(game.Workspace.Seat1) --Seat1 is a seat, that might help

Any help is appreciated. Happy New Years! :wink:

You have to specify the position as a Vector3 for the humanoid to move to as the first parameter. The second parameter is the part to move to.

I checked and none of them are working so far.

I modified my original reply. Did you look at it again? If the point is reachable (the map is continuous between the character and the target location with no blocks or obstacles) then the humanoid will move to that location. If the humanoid has to navigate obstacles, then you should use the pathfinding service to do it.

Here’s a picture of it. The seat is the position it’s trying to reach.

Is the seat an actual seat type or just a block made to look like a seat? Part of the problem may be that the coordinates are elevated above the floor. What happens when you run the test on the local server? Can you sit down in the seat?

Yeah, it’s a seat type. I’ll try it out.

edit: I can sit in it

Wait. Did you create this dummy using the Rig Builder tool in Studio?

No I didn’t. I’ll make one in the Rig Builder and see if it works.

Can’t you just move the character instead?


Ok, it won’t work using the rig builder. In the dummy, did you copy into it the animation scripts?

I don’t have any animation scripts in the rig (that I know of)

MoveTo is not a Instance it’s a Vector3 Position.

It didn’t work. Sorry!


Yeah, it’s not going to. You need the animation scripts package in the dummy to animate it so it can move. The only way that I know of to get those is to copy it from your client when you’re running the test server into the rig in studio.

I had this exact same problem and that’s what I had to do to fix it. There’s a script in your character called Animation or something like that. You need to copy that and the entire subtree into your rig.

@hollaquetalBRUH Already mentioned that. I posted a link to the documentation in a previous post.

1 Like

Did he tryed the solution ? It worked or not ? We need more informations about it.

Do you remember the name of the post so I can look it up?

I know what the problem is. The rig is missing the animation scripts. It will not move unless those are present.

1 Like

I never posted about it. I figured it out on my own.

HumanoidRootPart in anchord when you spawn a dummy, and if it is, then it won’t be able to move. Make sure HumanoidRootPart is not anchored.

1 Like