Multiple Tools in Roblox Studio Broken when Any Plugin is Enabled

We are continuing to investigate this internally. We believe we now have consistent steps for reproducing the issue. Thanks for your patience.

I have a similar problem but studio is broken even without any plugin enabled. It isnt broken the first time you re download it and open a place. Any other time you open studio its just completely broken.


I’m actually able to enable one of my plugins (Haven’t tried with more) and it works fine, but I only found this out by disabling all but that one.

We apologize for taking so long to address this issue, and are working on it as we speak. From what we have seen, the issue seems to be tied to the amount of plugins one has installed, whether enabled or not. One suggestion I have for a workaround fix is to uninstall plugins you are not using, or do not use regularly. If this does fix the issue, please let me know either by replying to this post or PM.
I will notify this thread on further updates to fixing the issue permanently.


I still have the problem as shown in my gif on my reply yesterday. I have uninstalled almost all of my plugins I only have a 8 plugins now and still have this problem :frowning:


I have had this bug a lot recently too, and I’ve tried reinstalling ROBLOX and ROBLOX Studio, and nothing seemed to fix. It’s like an 8/10 chance of happening, so I constantly have to reopen Studio over and over until it finally works correctly. The issue makes it so I can select multiple tools at the same time, none of which work. I also tried uninstalling all my plugins and it just doesn’t seem to work.

Hopefully, this is fixed sometime soon, it’s a bit of a hassle! :sweat_smile:


I also had this issue occur today around 1AM EST (10/13/2020).
I simply opened a group game through my browser (I only ever go through browser, Chrome, btw). During my session with the issue, I was going through my ServerStorage then attempted selected and object in workspace and after a flew reflexive clicks and attempts to press CTRL + 1-4, nothing happened. All tools can be selected in the top ribbon and stay selected (multiple), but alas doing nothing. I did notice my cursor was a blacked-in pointer triangle. Like the cursor you get hovering over ScreenGUIs. On further inspection, simply deselecting the dragger tools give the same cursor, so I assume some reason draggers were unable to be started during my session.

After going to a place on my account, everything worked fine, but I reinstalled studio anyway. No apparent issues currently after opening up the aforementioned group place. My normal workflow of opening places has yet to reproduce the issue.

I am currently having issues too. These have all only recently started happening. I’m not sure if it’s only when I have plugins on because I haven’t tried uninstalling them yet, but there are a lot of tools and features broken right now. This includes Roblox tools and the majority of my plugins are completely broken. I hope Roblox fixes this soon. Could any of this be related to the problems Roblox has been having over the past few days?

Hey! I’m 100% sure that the Roblox Staff’s are currently working on a solution for this.

Until this is 100% fixed, you have to close & re-open studio until you see studio is normal

i cannot make games or anything because of this, even the plugin management window is broken for me so i cant enable or disable any!?

1 Like

Multiplace universes also seem to suffer from this. My toolbox refuses to open or load nearly 100% of the time, my tools refuse to work 90% of the time.


  1. Open a place within a universe that is not the starter place using the game explorer/asset manager
  2. Bug should occur, your toolbox should not load, your tools may not work
1 Like

I’ve tried uninstalling most of my plugins, however I still have this issue. This issue occurs when I have 1 more plugin enabled, making it impossible to leave any plugins enabled when exiting studio.


I heard this occurs when you open studio from the roblox website (from search engine) but if you open it from the Roblox Studio App, it works properly… This has to be a bug from the main website I assume! But anyhow, until it gets fixed & the engineer’s tell us what the main problem is/was, we’ll have to wait haha

1 Like

I can relate. I have a dev project I am trying to work on consistently, and this bug is just completely taking away my ability to develop. I also have clients who are waiting for me to give them a product I can’t even make.

Small Rant:
I am a beta tester. I’ve tested multiple beta features, and the new select, move, rotate, and scale tools have been one of the buggiest features I had ever tested. Back when it was in beta, I tried it for just a few seconds to realize that the tools were completely broken. It didn’t take a few minutes, or even a few seconds. I turned on the feature and went to use the feature and it was so buggy, I was shocked that this was even in beta. I turned off the feature and went back to the old tools. I am just completely disappointed that Roblox released this feature even though it seems like the feature was completely broken. This is a full engine braking feature. Now multiple developers are losing time to this bug, and I am losing confidence in Roblox. I can not believe that a company that has grown to be one of the biggest gaming platforms in the world, which is now worth billions, would make a mistake like this.


I can understand your frustration on this 100%, haha! Think I’ve told this already on another post similar like this but I currently own a decent group & am doing decent job on it & for me to keep it active, I need to keep my game updated every week. I basically get in studio after school and from the problem which is going on in studio at this point, it takes me 15-20 minutes or sometimes hours (and then I just quit) to just get into my studio works. So in many ways it is wasting my time & is affecting me into my working times ALOT!

And I mean hey, on the other point, I’m glad that a staff actually responded to this topic & I’m hopeful that they’re working their best on getting this huge/mega problem solved! Until then, we gotta do the hard way! :sweat_smile:


I’ve been doing nothing major on Roblox Studio for weeks now due to this bug. I spend minutes trying to fix it, and just like you, I sometimes just give up. I am glad their engineers are working on it, but it’s just really… I can’t even use the word annoying or frustrating, it’s just concerning and infuriating because I knew that this new feature was buggy before the release, and I still see the same bugs. It’s very unprofessional.

1 Like

It was stated here earlier, but team create is a viable work around to this issue, and probably the best. You still won’t be able to work on non tc games.

Tldr: Enabling team create is the best solution for this problem atm.

1 Like

Just FYI this has nothing to do with the Lua Draggers release specifically, they just happened to start at similar times. There was a brief period after the Lua Draggers being turned on for everyone where this did not happen yet.

The root cause (which has been identified with a fix being in progress) is a race condition which has always existed in the code, but was just extremely hard to hit historically. That means there’s no single change that’s the culprit, just various changes to studio have lined up in such a way that it happens with a much more noticeable frequency now. We wish that there was a single change that we could revert to fix the situation (we would have done so promptly if that were the case), but there isn’t.


Thank you for your reply. I apologize for my earlier incorrect statement. I am glad the problem has been identified.

I have this exact same problem. You also experience this bug when opening a place from the Game Explorer.