Multiple Tools in Roblox Studio Broken when Any Plugin is Enabled

I heard this occurs when you open studio from the roblox website (from search engine) but if you open it from the Roblox Studio App, it works properly… This has to be a bug from the main website I assume! But anyhow, until it gets fixed & the engineer’s tell us what the main problem is/was, we’ll have to wait haha

1 Like

I can relate. I have a dev project I am trying to work on consistently, and this bug is just completely taking away my ability to develop. I also have clients who are waiting for me to give them a product I can’t even make.

Small Rant:
I am a beta tester. I’ve tested multiple beta features, and the new select, move, rotate, and scale tools have been one of the buggiest features I had ever tested. Back when it was in beta, I tried it for just a few seconds to realize that the tools were completely broken. It didn’t take a few minutes, or even a few seconds. I turned on the feature and went to use the feature and it was so buggy, I was shocked that this was even in beta. I turned off the feature and went back to the old tools. I am just completely disappointed that Roblox released this feature even though it seems like the feature was completely broken. This is a full engine braking feature. Now multiple developers are losing time to this bug, and I am losing confidence in Roblox. I can not believe that a company that has grown to be one of the biggest gaming platforms in the world, which is now worth billions, would make a mistake like this.


I can understand your frustration on this 100%, haha! Think I’ve told this already on another post similar like this but I currently own a decent group & am doing decent job on it & for me to keep it active, I need to keep my game updated every week. I basically get in studio after school and from the problem which is going on in studio at this point, it takes me 15-20 minutes or sometimes hours (and then I just quit) to just get into my studio works. So in many ways it is wasting my time & is affecting me into my working times ALOT!

And I mean hey, on the other point, I’m glad that a staff actually responded to this topic & I’m hopeful that they’re working their best on getting this huge/mega problem solved! Until then, we gotta do the hard way! :sweat_smile:


I’ve been doing nothing major on Roblox Studio for weeks now due to this bug. I spend minutes trying to fix it, and just like you, I sometimes just give up. I am glad their engineers are working on it, but it’s just really… I can’t even use the word annoying or frustrating, it’s just concerning and infuriating because I knew that this new feature was buggy before the release, and I still see the same bugs. It’s very unprofessional.

1 Like

It was stated here earlier, but team create is a viable work around to this issue, and probably the best. You still won’t be able to work on non tc games.

Tldr: Enabling team create is the best solution for this problem atm.

1 Like

Just FYI this has nothing to do with the Lua Draggers release specifically, they just happened to start at similar times. There was a brief period after the Lua Draggers being turned on for everyone where this did not happen yet.

The root cause (which has been identified with a fix being in progress) is a race condition which has always existed in the code, but was just extremely hard to hit historically. That means there’s no single change that’s the culprit, just various changes to studio have lined up in such a way that it happens with a much more noticeable frequency now. We wish that there was a single change that we could revert to fix the situation (we would have done so promptly if that were the case), but there isn’t.


Thank you for your reply. I apologize for my earlier incorrect statement. I am glad the problem has been identified.

I have this exact same problem. You also experience this bug when opening a place from the Game Explorer.

Just discovered another symptom of this issue: it’s preventing me from using the - to Roblox as… options in the File menu. Presumably because the Publish and Save To options are both widgets, the same issue causing default tools not to work also prevents the publish Guis from being made. No errors are generated when attempting to use these options, they simply don’t do anything.


I’ve also been experiencing this issue. I can’t open terrain, use the select/move/resize tools at all. I noticed it a few days back. It happens whenever I use a plugin. Sometimes restarting studio will fix it, but usually not. It’s really interfering with my work.

I’ve noticed it primarily causing this issue when I am on my Macbook Pro. When I use windows, it doesn’t seem to happen to me as often. I did noticed that the issue also seems to happen specifically on group places/online places for me. If I’m working on an offline save, the issue does not occur or at least hasn’t so far.

1 Like

Hello Everyone,
Thanks for being so patient about this issue. We have just shipped a fix for it, so please try it out and tell us if this issue is resolved.


Hi, it seems the bug is still there, but not exactly the same. All default ROBLOX tools are working, (Move, Scale, etc.), but all user-made plugins are not working.

(I have reloaded studio a couple of times, still no fix.)

Edit: I have loaded into many different places, still having the same issue.


Sorry to hear that. Could you PM me your Studio logs so I can take a closer look?


Upon further investigation, the fix caused some issues with loading user plugins, so we will be turning the fix off in order to resolve these issues.
In the meantime, we believe that the Studio tools being broken is tied to having user plugins enabled and opening Studio from the website, so opening Studio locally and disabling user plugins until after loading your Studio place should work as workarounds for dealing with this problem. We are treating this as a high priority problem and apologize for the inconvenience.


It happens normally, the plugins ain’t affecting me. All works if you open from studio, but if you open from the website it doesn’t. There is something wrong while opening from the website and since there is no other way to access places which are part of a game and the game explorer has the same issue as opening the place from the website. There is practically no way for me to work on those places properly. I have to load Terrain and all my work to another place because of this bug. You guys may know already that ToolBox, Terrain Editor, All Handles (Select, Move, Resize, Rotate). Those are all the broken stuff and the RobloxPluginGuiService is completely EMPTY, there is not a single DockWidgetPluginGui found in there…

Not sure if you mean turning off plugins doesn’t work, but if you don’t then that’s a solution to definitely look into. For others as well as myself, having all installed user plugins disabled when a place opens works around this bug. You can enable the plugin after the place loads and all should work fine for that session.

This seems to happen constantly, the best way to reproduce is using studio to open a new blank baseplate by using the little paper icon.

1 Like

What do you mean? If I disable each plugin everything will return to normal?

Correct. It’s the current temporary fix. It works for me.

1 Like

OHHH NOOOO! Ok, it worked pretty good until you open a new place. I opened a new place and the Roblox Studio crashed. If you click Plugin Manager it crashes Roblox Studio. I will have to delete Roblox and reinstall it…