Multiple Tools in Roblox Studio Broken when Any Plugin is Enabled

Here are some things I figured out when messing with the bug.

I enabled the plugins I wanted to use, then reset studio.
I opened up studio, and it broke the main essentials like the Toolbox, Select, Move, Scale, and Rotate.
I then tried disabling all of the plugins and resetting. This worked perfectly, In studio I then clicked Plugins>Manage Plugins> then enabled the plugins I wanted to use. This method works! but as soon as you reset studio with the plugins on, it breaks. This is hopefully going to be resolved soon as many of us are trying to develop games.

1 Like

This issue appears to only occur for me when starting a test server.

Every time i launch a test server, the tools dont work for player1 only, it is 100% reproduceable.

I have plugins installed but those are not selected or being used at the time.

Anywhere else in studio, the tools are working completely fine for me.

I’m having this too, I reinstalled Studio and then the stuff worked again but after I closed it again and re-opene it, the bug re-occured.

Started getting this issue today after studio updated

EDIT: seems fine now a day later, studio didn’t update or anything so no idea what the cause was

As did I. No change in how I build. It only occurred in a blank, unpublished place, but only seems to happen when I open a blank place file from the new place icon in an already open place. It doesn’t seem to happen when I open a blank place from the splash screen. Tool box disappears as well under these circumstances.

Same happened to me, could not use toolbox, move, select, scale, transform and others

This bug has been a huge problem for me. I have like, 15 plugins I need to use and my current work around is to disable all plugins and reenable them once I get into studio. This method is very tedious and time consuming. Also, I have to work with a spinning cursor the entire time I’m in studio…

1 Like

I’ve been having this for weeks now, don’t know why this is still an issue that hasn’t been fixed yet. This bug is extremely frustrating to deal with and has impacted development time.


We are continuing to investigate this internally. We believe we now have consistent steps for reproducing the issue. Thanks for your patience.

I have a similar problem but studio is broken even without any plugin enabled. It isnt broken the first time you re download it and open a place. Any other time you open studio its just completely broken.


I’m actually able to enable one of my plugins (Haven’t tried with more) and it works fine, but I only found this out by disabling all but that one.

We apologize for taking so long to address this issue, and are working on it as we speak. From what we have seen, the issue seems to be tied to the amount of plugins one has installed, whether enabled or not. One suggestion I have for a workaround fix is to uninstall plugins you are not using, or do not use regularly. If this does fix the issue, please let me know either by replying to this post or PM.
I will notify this thread on further updates to fixing the issue permanently.


I still have the problem as shown in my gif on my reply yesterday. I have uninstalled almost all of my plugins I only have a 8 plugins now and still have this problem :frowning:


I have had this bug a lot recently too, and I’ve tried reinstalling ROBLOX and ROBLOX Studio, and nothing seemed to fix. It’s like an 8/10 chance of happening, so I constantly have to reopen Studio over and over until it finally works correctly. The issue makes it so I can select multiple tools at the same time, none of which work. I also tried uninstalling all my plugins and it just doesn’t seem to work.

Hopefully, this is fixed sometime soon, it’s a bit of a hassle! :sweat_smile:


I also had this issue occur today around 1AM EST (10/13/2020).
I simply opened a group game through my browser (I only ever go through browser, Chrome, btw). During my session with the issue, I was going through my ServerStorage then attempted selected and object in workspace and after a flew reflexive clicks and attempts to press CTRL + 1-4, nothing happened. All tools can be selected in the top ribbon and stay selected (multiple), but alas doing nothing. I did notice my cursor was a blacked-in pointer triangle. Like the cursor you get hovering over ScreenGUIs. On further inspection, simply deselecting the dragger tools give the same cursor, so I assume some reason draggers were unable to be started during my session.

After going to a place on my account, everything worked fine, but I reinstalled studio anyway. No apparent issues currently after opening up the aforementioned group place. My normal workflow of opening places has yet to reproduce the issue.

I am currently having issues too. These have all only recently started happening. I’m not sure if it’s only when I have plugins on because I haven’t tried uninstalling them yet, but there are a lot of tools and features broken right now. This includes Roblox tools and the majority of my plugins are completely broken. I hope Roblox fixes this soon. Could any of this be related to the problems Roblox has been having over the past few days?

Hey! I’m 100% sure that the Roblox Staff’s are currently working on a solution for this.

Until this is 100% fixed, you have to close & re-open studio until you see studio is normal

i cannot make games or anything because of this, even the plugin management window is broken for me so i cant enable or disable any!?

1 Like

Multiplace universes also seem to suffer from this. My toolbox refuses to open or load nearly 100% of the time, my tools refuse to work 90% of the time.


  1. Open a place within a universe that is not the starter place using the game explorer/asset manager
  2. Bug should occur, your toolbox should not load, your tools may not work
1 Like

I’ve tried uninstalling most of my plugins, however I still have this issue. This issue occurs when I have 1 more plugin enabled, making it impossible to leave any plugins enabled when exiting studio.