Multiple Tools in Roblox Studio Broken when Any Plugin is Enabled

Something that I did was closing the place and re-opening it without disabling anything. It worked again the 2nd or 3rd time.

Been having this bug since early october. Super annoying. I made a threat about this as well but it was close by a forum moderator saying that this was a network issue. It fixes itself after some time but it reoccurs again the next day or in a few hours.

The Bug
In studio I’ll open my game file with two places, the starter place will have no issue with opening tabs, using tool draggers, and moving models. But whenever I open the second place from Asset Manager, all of the above functionality does not work. This bug started happening about a week and a half ago, and I’d estimate occurs about 20% of the time when opening the second place file from within the first. The bug will go away when I close out of studio and reopen the place.
Other Notable Issues

  1. Multiple tools will be “equipped” at once but won’t work or show up
  2. Draggers will not appear
  3. Tabs for toolbox, manager, etc, won’t appear


I’m unsure if there is a viable method of reproducing this bug as it seems to only occur out of chance within opening the place file.

Machine/Studio Info

  1. OS is a Microsoft Windows 10 Pro
  2. System Model is a Windows Surface Laptop
  3. x64-based PC
  4. Studio Verison is 0.455.0.413788 (64bit)
1 Like

I wanted to add to this, but I am also experiencing this bug as well. I recently had just noticed this bug a few days ago when I opened Studio, and I can see it’s still an ongoing issue for multiple users.

A bit late to the party, but yea, enabling team create seemed to fix this issue for me as well, strange

I have no idea if this has been 100% fixed or not but I just got into Studio & it loaded normally like it used to do. Has it been fixed yet? :thinking:

Yes, a fix for this has finally been enabled, thanks for your patience.

Please let us know if you’re still experiencing this.


Tools seem to work! Toolbox too.

Had a more limited but probably related issue where I have plugins that for some reason are unable to update, and in a game using plugins, was unable to use the grab/select tool (the mouse pointer).
I could only select using the window drag. Other than that, they behave as if locked.
I tried multiple times to move all the components of the game to a fresh baseplate, but the error followed some time during the transfer.
During the third or 4th time transferring (all in one session today), when I was writing down everything to be posted here. It … worked, and I have had not had an issue so far.
Basically, I was unable to escape it (for that game), and now am unable to replicate it.
(it might have something to do with plugin windows, and that state when the mouse has no tool selected). Hopefully I am wrong and this is just an annoyance, rather than it being right and having a new problem on the horizon.

I went into a script, exited, used the move tool, and voila, this game save is ruined also…
This is very much a problem. Trying to replicate on baseplate now. (had 2 plugins in the background, but it doesn’t seem to be plugin related at all).

I had changed names, parent-hierchy, made new instances, did not touch plugins at all, made a new script and added some code to it, was about to move positions, and BAM, its back.
That’s what I remember.
I am currently unable to replicate it.
All 3 ways of opening (from computer file, website, studio program) still have the error. (also doesn’t work on team create),(also also, I’ve been opening them one by one then closing, all while the original affected file is still open, incase that affects the result).

(some time has passed from my original post, it has not happened again, but the “original” file still has the issue, it probably has nothing to do with plugins)



For some reason I forgot to mention that the issue is resolved and was based around the collisions system.

1 Like