My Character is stuck, once you fall off the baseplate

First of all, I’ve been using the same rig for months, haven’t experienced the issue.

Recently I’ve been doing some testing on my game and I’ve encountered the problem stated below.

Whenever I actually Reset my character, he respawns in seconds (I’ve changed the respawn time to 0.)
But whenever I actually fall of the baseplate or map, my character kind of dies, but he gets stuck. The
only thing I could do at that moment is to move my camera around. (never respawns unless I reset)
That only happens with my Game-Rig, not with an actual Roblox character( as stated above the character has no issues whatsoever since this happened recently.)

This is what happens with my Roblox character:
HWpfzUJLqa

And this is what happens with my rig:
rrJD1mEEZy

This is also the character, showing that I don’t have any script or weird things inside of it.
Just a humanoid and the body parts
:

I have tried everything I could, including removing every single piece of my game and only having the rig.
Still won’t respawn.

That was so random, I wasn’t expecting that.
If anyone is able to help me I appreciate it!
P.S. I’ve done some research, this issue is the first to be addressed.
P.S.S I will answer any question.
P.S.S.S. The right Topic Category wasn’t available so I used this.

1 Like

Do you have a custom character loading script?

No this is just a Rig, that works like a normal Roblox avatar.
It’s named ‘‘StarterCharacter’’ and its placed in StarterPLayer like most Rigs on roblox

Incase @TheRealANDRO’s method doesn’t work try using a function for when the user dies to reload the character, for example reference:

haven’t read that yet but ill try. TY

Anddddddddd
nope. It did not work.
Tried Using both Local Scripts and Script.
Same result.

Does this error occur when you reset as well?

Nope it doesn’t.
Infact if i fall off the map, the only thing i can do in order to get out of there is to reset.

1 Like

Does the humanoid HP go to 0 when they fall off or do they just disappear in general?

When u fall off the map it disappears

I’m not too sure if this will solve it but does the rig have a part in it named “HumanoidRootPart”?

The rig does have a HumanoidRootPart.
As stated above this is a weird uncommon issue. The rig was working fine before this.

Does your character model have primary part as HumanoidRootPart?

When a player goes down the void it deletes all their parts, however there could be a method upon checking if the player loses their HRP and initializing a mandatory respawn. It’s only a thought but I know for a fact it’s possible.

My character does have a primary part as HumanoidRootPart

okay, thank you. Ill see what I can do with that

I just ran into this today. Make sure your requiresneck property of the Humanoid is true(should be default) and also make sure you have the correctly named Torso part in your character. My rig is R15 so I had to make sure I had a part named UpperTorso. For an R6 rig make sure you have a part named Torso.

2 Likes