My ENTIRE GAME broke from a Roblox update! (HELP NEEDED)

It could be multiple things.

  1. Do you have StreamEnabled on?

    • My thought process is that something might not be streamed in propely or you aren’t using :WaitForChild() or something. And thus, collisions of something doesn’t work in time. :person_shrugging:
  2. The following could be at play, not sure:


  3. Maybe you’re not actually reaching the ‘Humanoid’. Try printing the humanoid with :GetFullName().

Not sure what it could be, but I hope that helps.


sadly none is the case, and i’ve tried messing with streamenabled properties and turning it on and off.


So I just found out that copy and pasting all instances and properties to a completely different start place and rbxl works, but then when I move that rbxl over to the original game, it breaks again! How is this possible for the original start place to be “corrupted”? What am I missing here???

Same rbxl and everything. The solution I thought of would be to teleport everyone to “dekete” on join but then another problem occured. Once I teleport everyone to the place that works, suddenly even that stops working once the flood of players join! It literally doesn’t make any sense to me or all the other developers that I’ve talked to.


this is just a stupid guess, but maybe the issue is related to roblox servers or something?

ok another stupid guess for you: maybe theres a backdoor?

ok so this might be extremely obvious but it seems like the only reason this would normally happen is when the character doesn’t have a humanoid root part, you’re sure that carl has that right? (Maybe theres some issue where it doesn’t load when its laggy???)

ok nvm but that looks like there some problems with the humanoid root part idk

actually this seems to happen when the evaluate state machine thing gets turned off, and like even if you turn it back on it would still be broken idky


I had a somewhat similar issue to this yesterday with tweens. One of my tweens would move to the other tween’s position but only in the client version of Roblox. I was able to fix it by going to an older version of my game but I still don’t know what caused it. I am guessing that it is a Roblox issue but who knows.


idk if this is the issue, but when you turn off “evaluatestatemachine” for a humanoid, it just completely breaks even when you turn it back on, however, if you clone it, the clone seems to function just fine.
Screen Shot 2023-10-07 at 11.22.49 AM
(123 is a clone of 667 and is completely the same)
maybe roblox servers for whatever reason had it checked off at first???

idk might be related to this (it is a recent update afterall)

omg groovy im ur biggest fan


I had this exact issue and solved it by updating studio. Is it the latest version?


yup. all instance properties, all studio settings.


good guesses but yeah we’ve tried everything, even deleting every single script. im really starting to believe this is related to roblox servers because why else would it just stop working randomly after a flood of players


still happening even with every single script removed. absolutely everything removed, and yet its still happening only on this starting place, but not any other places. even with r15 as you can see the image below. ive confirmed that there arent any script issues, this is seriously a roblox issue.


Are the legs for some reason set to collide false?



I’ve seen this glitch/bug happening in the game Residence Massacre where for some reason the move to (or PathfindingService) seemingly didn’t work anymore/properly (There is a post to that, has been hidden tho). Tho it worked in a copy of the game, which was weird and then it happened 8 hours later. This issue was resolved however, no reason stated. It might be some real issue happening right now.


it’s probably John’s fault. (joke)

but seriously it’s so weird that Roblox don’t test updates before release.


Hey, I know this sounds dumb but try re-installing Roblox Studio, then open it again and test but in client after Publish. Someone else had this issue and they just re-installed Roblox Studio!!!


Maybe try overwriting the start place with ‘dekete’ in file> save to roblox as


pretty sure they did do that, but it still breaks when alot of people join


Are you saving it as a separate experience or just a separate place within the same experience?


update: This is 100% a Roblox bug, all NPCs are broken. Try it now, put a bunch of NPCs on a baseplate, free modeled or not, publish it to Roblox, then keep rejoining using Roblox client and NOT studio (they do not break in studio for some reason) until they sink to the ground permanently even after future rejoins. I’ve had a bunch of random people and devs test this out with same results. Will send a bug report to Roblox right now.


I’ve just tried this in a published game, using both toolbox models and a inserted character rig from the rig builder. I have rejoined multiple times and nothing has happened yet.

I don’t think roblox would have fixed this already so I might just be lucky.

Note: I saw a that a roblox staff member has replied to one of the posts about this and it will hopefully be fixed soon.


Sorry, just as I posted that I checked on the NPC game and saw it was back up and running at 500 players. Maybye I was not lucky and roblox have fixed it already.