My Luau Firebase RESTful API Wrapper

I would like feedback on both the code and the documentation of my project, thanks!


Github Repo

About your documentation…

Maybe you forgot some CSS.
I also tried on Microsoft Edge and it’s still not working.

Works on my phone, maybe it’s just your device?

Works for me as well (I’m on macOS Big Sur)

Your documentation has some missing parts:


Write documentation for Roblox Model.

Also, why would GitHub be more up-to-date than a roblox model? Does GitHub have some sort of auto-update. If so just tell people to use require() for your module.

I went looking at the console to see the loading errors.
All the CSS scripts are… missing ?

Could that plugin be doing it. Nearly every website has these errors including Microsoft.

I’m pretty sure he is aware of that.

Because he is most likely working in VSCode + Rojo and uses GitHub to store the code. Creating a new release takes time and you need to publish the model separately on Roblox. So, the most up to date code is always on GitHub.

This does not seem to be an issue on his end.

You can find an error on nearly every website out there.

I know. That’s why I said that this doesn’t seem to be an issue on @ShaneSloth 's end. Besides, the website is a preset + theme from a third party.

These errors don’t affect the website most of the time and since we can see it, it has to be a problem on his end.

No. I don’t have any errors in my console. It looks like some browser plugin that Lulu5239 installed may be blocking the css files.

1 Like

I generally don’t like supporting roblox files but it’s the most accessible format. I work in VSCode and use Rojo to sync files into studio.

I always push updates to the Github first after testing, building/updating a roblox model is a little bit extra work on top of everything - that and I rarely remember its existence.

Could you try disabling any extensions you have installed and then try accessing the documentation?

This uses a prebuilt theme called Material MkDocs if we can figure out the root cause I could possibly file an issue over on their Github.

I just checked out the url, and it’s invalid. I’ll have that fixed ASAP!

Issue is on the site’s end, no worries.

(Assuming you click the link to transferring data from home page)