Name system stopped working after attempt to modify

Hello! I recently have been wanting my name tag system modified, so my scripter went and modified it, however, when I finally tested it, it didn’t work. I know almost nothing about scripting and my scripter is away from home. I have tried getting the script to work but I was unable to, so I decided to come to the devforum for help. What I want the script to do is make the text change color if the user has a certain gamepass, but when I tried fixing it, the text stopped showing. I am unable to fix it, plus my scripter is unable to work on it for a while, I hope you are able to help me!

The script

local TweenService = game:GetService("TweenService")
local MarketPlaceService = game:GetService("MarketplaceService")
local Player = game:GetService('Players')
local GuiClone = script.Frame.OverheadGui:Clone()
local UIDisplay = script:WaitForChild("OverheadGui"):Clone()
local frame = UIDisplay.Frame
local BottomText = GuiClone.BottomText
local TopText = GuiClone.TopText

local gamePassId = 17893781

		char.Humanoid.DisplayDistanceType = Enum.HumanoidDisplayDistanceType.None
		frame.Parent = char.Head
		frame.TopText.Text = Player.DisplayName
		frame.BottomText.Text = ("@"..Player.Name.."")

		if MarketPlaceService:UserOwnsGamePassAsync(Player.UserId, gamePassId) then
			while true do
				local Color =, math.random(), math.random())
				local ColorTween = TweenService:Create(BottomText, TopText,, {TextColor3 = Color})


Extra info
The script and everything is in ServerScriptService

1 Like

Quick question, it could be my vision but why does the script look like its been disabled? If it is, you can change it in the properties of the script.

I have the script disabled until it’s fixed

I disabled it after I ran out of ideas on how to fix it

Ohh. Thanks for the clarification, I’ll check over it right now.

Alr, tysm. I suck at scripting

When it runs the script, do you have any errors or does it just not work?

It doesn’t work, doesn’t show any errors. Idk why I typed nothing pops up, lol

1 Like

Hm, I can’t figure out why it wouldn’t work, don’t worry though, someone who is more experienced than me can figure it out. Sorry that I couldn’t fix it.

First of all, have you tried reverting script versions?

I forgot to mention that I tried fixing it so it would change color, but it ended breaking the whole thing, it never worked properly in the first place. Sorry for the late response