Nan, nan, nan on position

I keep attemtping to move models ingame, and the position changes to this, or with a ridiculous y-position value. Any fixes?


Since I don’t know what models you’re trying to move and how packed the game is, I’d recommend you to disable all of your plugins and beta features and see if this movement issue happens again. If it still happens, try moving something simple like a Part on a baseplate, if that works then there’s something in your game that’s glitching Studio or one of your plugins out.


You aren’t giving enough info. Considering the orientation is not a decimal, I have no idea what is causing the issue since it seems like an anchored model.

Its a baseplate. It is nto packed at all and a new game.

Yes, we are talking about the position, not the ortientation though?

Alright, what is the pivot point set to?

Just the middle of the item. Its a FM drone im attempting to redo, however, I have tried on other models, it does the same thing.

is this happening to you? i was about to post about this. its either nan,nan,nan or some crazy number. only able to move parts via free transform

studio was working fine earlier today

EDIT: this may be a studio bug.


the same thing happens to me
(edit: the video quality is low)
edit: when i move the part it moves to “0, -340282346638528859811704183484516925440, 0”


This has happened before attempting to update, Or demonstrate the bug.

1 Like

Hi, I found a solution. In the tab where you can change the move interval, mine was originally at zero. I tried changing the value and this seemed to work. However, I can’t go back to 0. I think the lowest is 0.02 now for me but I can’t check right now.


I think it has something to do with the studs number. Not sure


exactly the same as mine, just change the studs move unit, don’t make it 0, change it to 1 , go to model tab, it works for me, hope it helps

go to model tab, then change the move value , try change the unit e.g. 1 or any number then try again, hope it helps

I’m getting the exact same error.

@tnavarts discussed a fix for this. Take a look at their post.

Okay, I tracked this down. If you explicitly entered “0” as the last grid snap before I made the change to grid snapping today you’ll get the bad behavior until you set another non-zero grid snap.

I’m going to leave the flag on for now because it’s the same flag that fixes the really-annoying-problems-typing-into-the-gridsnap-box issue, but I’ll reevaluate tomorrow morning.

Do you think this is a workflow problem? The new behavior is that if you type zero it disables grid snap entirely instead of giving you an effective grid snap of 0.01 like it did before.


I just got this error myself. the part/mesh objects in game just teleport to position nan, nan, nan or a very high number. It appear to just vanish on screen but the part remains in the game. I can’t move anything atm.

1 Like

Same, I am unable to move any part, I am using F3X to move parts or models

If I move a part, its goes to 280282392332023 in Y axis

1 Like

this person solved it!! When object is being moved, its position glitch

1 Like