Need help fixing non 1 or 0 alpha values on pixels surrounding ui. (Black outlines)

This has been a problem that has persisted in roblox for awhile. It specifically revolves around roblox rendering alpha on ui that is not 0 - 1 on the ui border as completely black pixels which look like this:


The ui element outside of roblox looks like this:

I’ve tried everything on this post here: Fixing images in Roblox ui (black outlines) - #6 by Mistertitanic44
From gimp plugins, pixel fix and Photoshop to online js executors. Nothing has resolved this issue. I’ve also been told it has nothing to do with image px size either. Which sure enough when I tested different sizes did not fix the alpha. The only thing I’ve found to have worked is manually removing the transparent pixels which of course takes a massive amount of time and isnt something I’m going to do. I’m very confused with this problem and I have no idea how to solve it and how other developers solve it.


I used to solve it using the alpha bleed GIMP 2.0 plugin, but my macbook refuses to open GIMP anymore because it’s not an application from an approved developer. Try using this open-source solution: GitHub - Corecii/Transparent-Pixel-Fix: Changes black transparent pixels to match the nearest color for proper blending.


Pixel fix dosent work for me, strangely, I installed it yet it dosent actually do anything to the image i sent in. I retried the gimp bleed transparency and apparently I need to be running it multiple times on the ui to get the desired effect. Thank you for the help.


you can bypass the .app security thingy via system preferences/system settings i think