{NEED HELP} Weird hovering over my mesh

So I made a low poly pirate ship in Blender but when I exported it to Roblox, my Roblox character is hovering on top of the boat. Is there any way to fix this issue.

4 Likes

The collisions are not working properly. Make sure that the “Collision Fidelity” property is set to “Default”. If that does not work, then try configuring the mesh in Blender and then try importing it again … ?

1 Like

Where can I find this “Collision Fidelity”, is it supposed to be in the properties of the model?

1 Like

Is the ship a mesh part? If so the property is in there. If it is a part with a special mesh in it, then use mesh parts instead to get best collision results.

Yes the ship is a mesh part and i found the Collision Fidelity but its already set to default.

collision%20fidelity

Roblox’s external CSG system is horrible, however we can help you process all this information, I would consider selecting the mesh in blender (during edit mode) and pressing CTRL + T to triangulate the faces, but if this does not work, you will need to separate your mesh into several parts.

1 Like

Even after use the CTRL + T to triangulate, it still hasn’t fixed the issue.

So,

You could separate it in more parts to get a better collision, select some faces in edit mode and press P.

Meshparts are terrible for physics collision calculations. they’re laggy and inaccurate.

your best bet is to use Hull fidelity if raycasting is needed, and then creating your own physic parts for it.

This happens due to a weird glitch whenever you make a mesh that’s “stretched out” (if that’s even the word). I suggest making the boat piece by piece and put them together in Roblox studio, or just plain out turn off collisions.

If you’re still having trouble with it, a less conventional solution would be making the whole mesh CanCollide false and placing invisible blocks where the ground/masts would be interacting with a player. Only do this if all else fails because it is unnecessarily time consuming and, depending on how well you do it, less precise than adjusting the mesh itself.

https://www.youtube.com/watch?v=TJcO1sGWvpM This solves your issue?

(I did not make the video).

1 Like

I have experienced many problems with meshes… There’s some option in the Studio Settings where it shows you where blocks will collide with meshes. As the Collision Fidelity is automatically set to default, I believe there is some kind of error when it sets to default for the first time- because when I set it to ‘Box’ or ‘Hull’ then back to ‘Default’, its collisions are more accurate and probably good enough for your build.

You might want to use a plugin like this if you’re having issues with mesh collisions

Just turn off the collisions on the mesh you made in Blender and make the Wedge group that got generated invisible and you should be good
I recommend using lower poly models since there will be less wedge parts in the game, the excess amount of parts would be bad for performance