Need help with this bug

Hello, so i’m using Fe Gun Kit, and there is this one bug, that I cannot figure out. I’ve changed the name, I’ve done almost everything I could think of, could someone check and see if there’s something wrong with line 388?


1 Like

Just tried it out and it worked without any problems. Line 388 you showed is line 439 for me, what happened to the rest of the code? I suggest you try inserting the kit again.

Please show me the module script placed in Camera.Arms named “offset”

It just says “-- Decompiling is disabled”

There’s TONs of Edited Fe Gun Kits, I’m using “Als Edited Fe Gun Kit Viewmodel” You could be using a different Fe Gun Kit.

That’s the only line in the module offset?

A module script HAS to return exactly one value. If it doesn’t do this, it will throw an error.

Yep, this is what It says.

1 Like

That’s weird. Can you enter code in it?

If you can, replace it with this:

local module = {}

return module

This is the basic ModuleScript setup.

1 Like

Sadly, it didn’t work. I’m just going to use a different kit. Thanks for helping me though!

1 Like

Hello! So, I was able to fix what was going on. So I was using my custom Viewmodel Rig, I took a look at the Viewmodel rig that was used for the Kit. The Module Scripts were two completely different things. So, you were technically right. Thanks for the help!

1 Like

AL’s Edited version is Outdated and could result in errors flooding, I’d recommend using the latest version of FE Gun kit Viewmodel instead.