Nested packages no longer respect the AutoUpdate property

Reproduction Steps

  1. Create a package from a “Folder” instance
  2. Create a “Script” package, place it within the folder package
  3. Publish your changes to the “Folder” package
  4. Insert a second “Script” package into the workspace
  5. Change something about the workspace “Script” package
  6. Publish your changes to the workspace “Script” package
  7. Observe that your “Folder” package now requires you to publish it to get those new changes, it can no longer AutoUpdate
A less abstract example for clarity


My “GameCore” PackageLink is set to AutoUpdate. It contains several packages within it, namely “global_Banlist”.

I use these packages in other experiences, but I only use the “GameCore” package in this specific experience.

If I ever update global_Banlist, my GameCore package is rendered useless. It will never automatically update. I have to manually “discard” the changes for it to automatically fetch the most recent global_Banlist. Conversely, I can erase and re-insert my GameCore package - which is the whole thing packages is supposed to prevent.

Expected Behavior
The topmost package should automatically fetch the newest version of its nested packages when “AutoUpdate” is set to true. This used to be the case; otherwise, there’s no point in having “AutoUpdate” inaccessible for the nested packages.

Actual Behavior
AutoUpdate is now useless with nested packages. You must either “publish” the new change on every occurrence of this main package, or you must erase and replace each package manually.


Issue Area: Studio
Issue Type: Other
Impact: High
Frequency: Constantly
Date First Experienced: 2023-02-01 00:02:00 (-08:00)
Date Last Experienced: 2023-02-01 00:02:00 (-08:00)

As an update to this report, I tried reproducing it again today, but this issue appears to only happen sometimes. It potentially may be an issue with having two places open at the same time?

Which in that case, this may actually be intended; albeit not necessarily intuitive. Will look into seeing what makes this bug occur with 100% accuracy.

Can’t seem to reproduce this bug anymore. Not sure what’s up. Might be user error, marking as solved. Will repost if it happens again.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.