Network OwnerShip API cannot be called in Anchored parts or parts welded to an anchored parts

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    I used Phantom’s AI Version 2 Script and it doenst work

  2. What is the issue? Include screenshots / videos if possible!
    it says Network OwnerShip API cannot be called in Anchored parts or parts welded to an anchored parts

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    i deleted WeldConstraint in other parts
    After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

error =

- -script.Parent.HumanoidRootPart:SetNetworkOwner(nil)

Please do not ask people to write entire scripts or design entire systems for you. If you can’t answer the three questions above, you should probably pick a different category.

and what are these??
GetCollisionGroups is deprecated, please use GetRegisteredCollisionGroups instead. More info: Updates to Collision Groups
CreateCollisionGroup is deprecated, please use RegisterCollisionGroup instead. More info: Updates to Collision Groups
SetPartCollisionGroup is deprecated, please use BasePart.CollisionGroup instead. More info: Updates to Collision Groups

if script.Parent.HumanoidRootPart:CanSetNetworkOwnership() == true then

Also I suggest not putting a script under the Player.Character instance. Exploiters can remove the script iirc.

I think all you have to do is rename the functions you’re calling. For example, switch GetCollisionGroups to GetRegisteredCollisionGroups.


is it?

Those errors, I assume, are coming from your code, not from the collision widget.

1 Like

im rlly srry but i didnt understand

If you’re getting that error in Roblox Studio, some code in your game is using the functions GetCollisionGroups, CreateCollisionGroup or SetPartCollisionGroup. The way to fix these errors is to rename them:


You can use Ctrl+F if you’re on Windows and you can try and find the code that’s using deprecated function calls.

Also, did my code fix your SetNetworkOwner error?

1 Like

that didnt work, but i fixed it i dont know how did i do

im very sorry that im stupid, but if i use ctrl + F, nothing happens

You’re not dumb, I gave you the wrong instructions:


1 Like

Thank you so much, its working

1 Like

These aren’t very good answers, nor are they very helpful to what the OP is asking, I’ll try to provide more relevant info:

This means:

  • One of your Items is Anchored

  • An Item is Welded to the Anchored Instance

This doesn’t mean that Network is disabled, it means that there is something preventing you from applying it, Network Ownership works by assigning an owner to someone or something so it can calculate and Simulate Physics, It is automatically assigned to a Player by the Server, but you can change this by using the function: SetNetworkOwner which applies Ownership to an Instance and not just a Player.

If the Instance is Anchored, Network Ownership wont work as there is no Physics being applied for the Instance under those conditions, so if you unanchor it, it will allow the Server to Simulate Physics with the Instance.

These are not errors and I’m not sure where you heard that from, these are warnings, the warnings are to indicate that the function is Deprecated, which basically means that the following is discontinued, or obsolete compared to other methods. It is generally recommended that you avoid these methods as basically anytime, they could break due to their deprecation

As you already said,
They should be Replaced with the Following:

GetCollisionGroups with GetRegisteredCollisionGroups
CreateCollisionGroup with RegisterCollisionGroup
SetPartCollisionGroup with BasePart.CollisionGroup

These new functions are the newer Variants to the Obsolete, this could be because:

  • The Newer is faster than the Old

  • The Newer is more Efficient than the Old

  • The Old is no longer compatible with the newer version of Luau
    (The Coding language of Roblox)

And should generally be replaced with these newer variants.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.