New Animation Editor Announcement



Rename keyframe was turned back on yesterday. Most of the other issues mentioned in this thread are being worked on right now, and should be released with future Roblox Studio releases very soon


To be honest, this new editor feels rather like a downgrade. It’s now more tedious to make new animations, and especially the fact that we can’t copy/paste keyframes just makes it almost unusable for me.

Now I’m not saying this is bad, but it can definitely be improved.


If there’s any way to install the previous animation editor, I’d like to know.


This plugin is the old animation editor:

Also, the new animation editor is still underdevelopment meaning it actively being improved upon. I’m sure copying and pasting keyframes in on their roadmap already.


Thanks! And if it’s still in development, they should’ve probably released it a bit later.


FYI, functionality to copy/paste entire key frame will be available tomorrow :slight_smile:

We will also release functionality to drag and select multiple poses to copy/paste very soon.


I don’t seem to be able to copy/paste poses. Once I copy a pose with either Ctrl+Shift+C or the context menu, pressing Ctrl+V pastes the last part I copied outside of the editor instead of pasting a pose.

On a separate note, even with keyframe snapping, somehow I still ended up with the editor selecting a keyframe 0.001 seconds away when I tried to adjust it.

Also, the context menu doesn’t invert direction when there’s not enough room on one side. Expected behavior is that it prefers the direction with the most available space if there’s not space in one direction.



We’ll look into these bugs - thanks for the feedback


Could you please fix the animation editor forcing itself open every time I open/close play solo. I never even opened up the plugin since the new UI came out (happens on 2 of my machines).


Does it happen if you open/close the animation editor and enter/leave play solo again?


has this just started today?


Yes, and no @EchoReaper, that didn’t fix the problem.


I’ll look into fixing this straight away - thanks for flagging this.


Hey EchoReaper, thanks for bringing this to our attention! Just need to get some clarification on a few things. Could you explain what you mean by pasting the last part you copied outside of the editor?

For the keyframe snapping issue, is the issue that it’s only snapping to the keyframe that is 0.001 seconds away and not the keyframe directly before it, or something else?


Not being able to select multiple keyframes to copy/paste or set their easing style all at once makes the workflow for this updated version quite unintuitive to me. Is there an available plugin of the old editor anywhere in the meantime (or any suggestions)?


Buildthomas made a copy of the older one that you can use, posted here:


Repro steps:

  • Copy a part/model to the clipboard
  • Open the animation editor
  • Create a pose
  • Copy the pose with either Ctrl+Shift+C or the context menu
  • Press Ctrl+V

Pose is pasted

The part/model selected earlier is pasted, and the pose is not:

Of the two types of snapping the animation editor supports:

  • Timeline cursor snaps to certain increments (e.g. 0.1 seconds), regardless of whether there’s a keyframe at that time
  • Timeline cursor snaps to nearby keyframes, regardless of whether they’re on the previous snapping grid

this is an issue with the first. For some reason, the editor determined that it should snap to 0.494 on one occasion, and 0.495 on another occasion. Snapping should be determinant and always snap to the same position. It seems like the snapping math doesn’t have enough precision – there’s the issue of indeterminate results, but also the snap targets are way off mark. I can understand 0.19999 because of floating point, but some of these snaps are off by 0.006.


Takes up way too much window space, its buggy, and has a lot of issues. I will be going back to the original version. Some plugins just aren’t made to be widgets / docked. This is one of them.


All I see is image

But when I uploaded it, it works fine now! Thanks!


Fixed in both. There was another toolbar that said “Legacy Animations” that did have the buttons.