New mesh system problem

Im trying to import an .FBX file using the new (beta) mesh importer. I am downloading collada files from the Sketchup “3D warehouse” and then importing them into blender, exporting them as .FBX in blender and importing them into Roblox with the mesh importer.

On almost every FBX I import, it says for the “File Dimensions” inf,inf,inf. I tried exporting alot of .FBX files but all of them have the same issue:

image

The meshes also appear transparent but all meshes are still there.


I tried importing alot of meshes but they all have the same issue.

2 Likes

I have the same issue, I am not sure why its happening?

2 Likes

Are you able to import them back into Blender from the .fbx files? If so, make sure that the objects which you are using do not have extraneous points and contain geometry - either of those may mess with import in unexpected ways.

As an aside, I highly recommend against using assets from SketchUp’s 3D warehouse, as they are typically incredibly unoptimized and often have many severe topology issues due to the limitations of the SketchUp platform.

I have a fix

Basically, go thru the list and find the object which is giving the position -inf, -inf, -inf or inf, inf, inf then go into blender with the object and remove it, re-export your FBX and it should work fine.
This works for me atleast.

5 Likes

Probs a very late reply but, a fix for this is to find the mesh that has no vertices. This mostly bug out the whole unified mesh importing system. You can use Asset Manager to find the mesh with no vertices.

1 Like

Idk, I have never seen that happen to me before I would just try reuploading the mesh. Thats all I can say.