New Particle Orientation system gets visually buggy with larger particles

I agree with this, it looks like you’re dealing with Z-Fighting here and not any bug Roblox could possibly fix (particles probably use polygons to render just the same as any other mesh in the game does)

Yeah I’ve noticed. Its a super awesome feature just its sad its kinda broken.

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.


I’ve had the same problem. One thing I discovered is that this does not occur if the particle is floating somewhere above the skybox, as shown here:

When I move it to a place above a part, it is clipping once again, shown:

Thanks for taking note, cant wait for when you guys fix this.

I am also having this bug. I found out that lowering graphics quality makes the clipping lessen but at the cost of quality. The bug seems to affected by the camera angle + distance regardless of where the particle is positioned. I really hope this gets fixed soon!

(at graphics quality 10 to 8, the particle goes under..?)

(lowering graphics quality lessens to clipping, but is still present)

It gets worse the more I move my camera but you get the gist.


Any updates on this bug report? I am still having serious Z-Fighting issues trying to create even decent looking visual effects with multiple particles not just on the same plane, but overlapping eachother in general.

An update to this issue would be greatly appreciated so that I can ship effects like these ripples without worrying about them compromising the visual integrity of my showcase. Thanks for your time


I would like to confirm that this bug is still occuring, any updates on this matter? It has been a while since then

1 Like

Even to this day, this bug is still going on, I REALLY need a fix.


Can confirm this bug still happens and it’s effecting my game heavily. Can we get an update?

1 Like

Bump, I thought I was mentally going crazy but I feel at ease seeing other people have the same problem as me. I hope they fix this…

I’ve been having this issue since particle orientation was released, and it doesn’t seem like this feature has gotten looked at since it dropped. This is an extremely useful feature for VFX but it’s being killed by its bugs.

edit: While messing around with this, I discovered that it starts bugging out at the edge of the screen on graphics levels 8 and above, and the particles get culled on every graphics level despite still being on screen.


This bug is still present, are there possibly any updates?

1 Like

The bug seems to be fixed on a higher zOffset and a higher Brightness

Make the size of your particle larger than 1 using code, works in studio too using the command bar for example try this out:

ParticleEmitter.Size ={,2),,2),,2)

Just run something like that on any particle emitter and zoom into it no matter which ZOffset or Brightness you put it’s gonna get visually glitched on any graphics above 7 or 8 not sure and if you aren’t in live game/playtest then any studio graphic level above 15 makes it glitch too.

We have a proper fix for this on the way. (in video, red: with fix, gray: buggy before)


I only recently started getting this strange visual glitch, when moving the camera with particles.

FYI a separate thread has been made on that bug:


I just flipped the flag that hopefully should fix this. If it doesn’t, please send me a direct message. Thank you!