New Roblox items are buggy when released

  • Describe the bug. Describe what is happening when the bug occurs. Describe what you would normally expect to occur.

This bug redirects a lot of new items, including the recently released Noob Attack limited, to the catalog, instead of the actual link itself.

This link will most likely be fixed.

  • How often does the bug happen (Everytime/sometimes/rarely)? What are the steps that reproduce the bug? Please list them in very high detail. Provide simple example places that exhibit the bug and provide description of what you believe should be the behavior.

The bug happens every time on the above link. Simply click on it in the catalog and you will be redirected. Any other item doesn’t do this.

  • Where does the bug happen (www, gametest, etc) Is it level-specific? Is it game specific? Please post a link to the place that exhibits the issue.

On the catalog.

  • Would a screenshot or video help describe it to someone? If so, post one.

Proof (using a Google Pixel 2 XL on Android P Beta 1)

  • When did the bug start happening? If we can tie it to a specific release that helps us figure out what we broke.

It’s been happening since the start of the year at least.

It has been around 10 minutes and I still cannot view the item. I will be posting the links of all future items that are affected so that this problem may be easier to fix.

Many thanks,


The gif you attached seems to be a static image (EDIT: fixed). (Also I fixed the link reference for you)

I’ll check out the gif right now, thanks Thomas.

The source to that link is
Same to you in your thread, Younite.
Is this a problem posting links, rather than a problem with accessories?

1 Like

I tried it on mobile just now. Does not work when I click on it while on the catalog.

Oh so this isn’t a problem with the link, this is the catalog in general? You just can’t get to the page of the item?

1 Like

It seems to fix itself after a while, but it never used to be like this.

Both don’t work actually.

Not sure if it’s relevant, but I can’t even find Noob Attack: Fallen Artemis on the catalog:

I enabled hidden items too, it’s not there.


I’ve been frequently experiencing this issue too.

For every new items that were uploaded recently in the past while.


I had this same issue back in January, thinking it was a one-time bug. However, this seems to happen with every new limited that’s been recently released. As you can see, I can click on other items that aren’t limited.



EDIT: many other users are having this issue as well, many others are not


hope roblox gets to the bottom of this, ive been driving me insane.

I as well, I get quite panicked when a limited item’s stock is going down while I can’t even click on the item to purchase.


yeah im the same.

1 Like

Another broken link:

Issue still not fixed. Cannot view this item.

1 Like

Uh? It’s saying it’s just the catalog.

1 Like

The redirect is supposed to combat botting, but it’s not doing its job, and actually affects us, the regular buyers, while this happens with the new beast mode.


What baffles me even more about this is the fact that they’re even going beyond the barrier that stops them from buying more than one Limited U until its stock has sold out.

1 Like

That’s definitely an issue. Items sell out in under a minute giving most people no chance to see it appear in the catalog. Let alone purchase it…

1 Like