New translations bug for experience

Reproduction Steps
New translations were added last Saturday for an update. After a while we noticed that the translations didn’t work in game. Tried looking the in the setup and everything looked fine. Tried to download localization table and upload it again. Tried to upload table to different game, and the translations worked. “Use Translated Content” is of course also on. Old game strings works fine, but not the new ones.
So it seems like it’s something wrong with the game itself since it worked on other games.

Expected Behavior
That the new game strings will work in-game.

Actual Behavior
New game strings doesn’t get translated in game, only old strings.

Issue Area: Engine
Issue Type: Display
Impact: Very High
Frequency: Constantly
Date First Experienced: 2021-10-23 00:10:00 (+03:00)


Thanks for the report! Will have this investigated.

1 Like

Hi, thanks for the report. Would you mind sharing some examples of translations which were not working properly as well as where they were used?

1 Like

Forgot to mention, this happens in Car Dealership Tycoon

1 Like

Example in the intro when you enter the game. You see those with red line are new translations that are supposed to be translated, but doesn’t work. The line in blue is an old game string, which works.

1 Like

Hey Foxzie, just checking in on this issue again. We’ve made a lot of improvements since, and it looks like this issue is now fixed in your experience? Can you confirm?

Hey @Foxzie - just following up on this one more time. Can you please let us know if you are still experiencing this problem? Thank you!