No edit permissions even though im the owner

This is a support category for asking questions about how to get something done on the Roblox websites or how to do something on Roblox applications such as Roblox Studio.

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    I want to be able to access my place through the roblox studio
  2. What is the issue? Include screenshots / videos if possible!
    Whenever I try to access my place through roblox studio I am prompted with the message “You no longer have edit permission to the selected place. It will be removed from this list.” Even though I’m the owner of the place and game.
  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    Restarting my pc and roblox. I can edit the place from the creator dashboard but not studio.
    After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

I have just run into the same issue when i tried to open my games in studio even though I’m the owner/creator of them and the only one with permissions.
For me it seems to only be the games under the Recent tab. I switched to the My Games tab and all my places were still there and I still had access to them.
Not sure what is going on.


I am having the same issue too! I had to switch to the My Games tab as well.


It doesn’t work for both recent and my games.

1 Like

I am also having this issue! Using My Games seems to still work though.

1 Like

Likewise, I too received this message and then it just removed the place in Studio. I was able to open it again from the My Games tab.


This did just also happen to me.

Same to me, i managed to open it only in the website