No intellisense support for Wally

I’ve switched over to Rojo recently and along with that came Wally, a package manager. When I require modulescripts from “Packages/” there isn’t any kind of intellisense in VSCode (No suggested functions, can’t find nested modulescripts).

I’ve created a “$path” to “ReplicatedStorage/Shared/Packages” from “Packages/” in the Rojo configurations, but Rojo doesn’t register this (ReplicatedStorage/Shared/Packages is empty in VSCode).

FYI: “Packages/” is in the main directory of the filesystem.

Does anyone have a fix for this?

Wait have you tried to get the ROBLOX LSP VSCode extension?

Also congrats on the switch, very impressive!

I personally use this one

image

2 Likes

I have the same extension, made by another person though
image

This only happens with packages managed with Wally by the way. ModuleScripts within src/ behave as expected. I tried using that extension but it also doesn’t recognize the packages.

It seems like I fixed the problem, although I don’t know exactly how. Maybe Rojo needed to start to do some stuff so that everything is correctly set up
EDIT: no, nope, that’s not it

1 Like

i think i found it out…
image
EDIT: Replace “Packages/**” with "**/_Index/**"
EDIT2: I am so tired