No sound in Roblox Studio

My Roblox Studio doesn’t play any audio when playtesting and sometimes even when previewing audios in the library, I have searched for any potential fixes on the internet but all I’ve got is “change your volume in the ESC settings when you’re playtesting” but I’ve already done that yet no sound is audible

Sometimes it fixes by itself or when I change the volume in the audio mixer settings
Any help is appreciated.

Edit: If this is in the wrong category, ask me to change it
Edit 2: Apparently alt-tabbing temporarily fixes this


This is the first time I hear this, but try to restart Roblox Studio or leave from the Roblox Studio, adjust in mixer setting and restart Roblox Studio. If it’s not helping then I’m sorry :face_with_peeking_eye:

1 Like

Thanks for trying to help, but this doesn’t work.

1 Like

First of all check Esc > Settings > Volume…

Anyways I experience it in some playtests too…

1 Like

I’ve already said that it doesn’t work, tried that more than once

1 Like

I feel like this is a current ongoing roblox studio issue right now. I started getting this issue a few days ago but whenever it happens to me, i click onto a random application for a few seconds and then click back onto roblox studio and it fixes for me. It seems to only happen when you click off the application from what i have found out. Let me know if this at all works.

1 Like

First, obviously check volume for both studio and your pc. That’s simple. But what you really need to do is make sure studio is focused and check your audio device. There’s one in settings as well as on your pc. Also, make sure the rest of your pccan play audio. Sometimes audio drivers break for no reason. Also, does studio need an update?


Been experiencing the same thing, too. Started a few days ago for me as well. It sucks when you’re making a boss fight and can’t listen to the music or sound effects.

…this could probably be marked as a studio bug?


Try to test the game from studio, and increase the game volume from the menu settings. I think this is the reason why this is happening.

1 Like

This is the same thing for me, but I know the reason why.
Its probably because roblox deleted your or others audio for copyright reasons I believe so.

1 Like

Studio is updated and so are my audio drivers, sometimes unfocusing studio and re-focusing it while playtesting makes the audio work again only for that session.

Yet again, I have constantly changed the audio via the esc menu when playtesting and also in the mixer settings but the problem persists, reading thru all these replies leads me to believe this is a bug on Roblox Studio’s end.

Sadly I can not change the category to Bug Reports as I don’t have the permission to post bug reports.

This is unrelated, no sound plays while playtesting (and rarely on studio) not even the usual Roblox sounds can be heard.

this started happening to me few days ago, I just click somewhere on my desktop and then somewhere on studio to fix it temporarily. Should be a bug.

this been happening to be SOMETIMES and its annoying to go to Test > Audio and click Mute twice to solve it.
it is a bug so you should make a message about this bug here with all reproduction steps and things.

attached photos of where can you find this button


Do you still need help with this? I can give you some help.

1 Like

Does it give you an error at the bottom of the command prompt?

No, I don’t get any errors related to sounds.

I’ve already submitted a bug report thanks to @vvv331 's reply but anything helpful to fix this is always appreciated.

Sometimes this happens even if the music I’m listening to is either paused or I’m not listening to any music at all.

This started to happen to me recently. I fix it by spamming mute button in the test tab on the top menu

1 Like