No way to disable autocomplete on enter

Unless I’m missing something, there’s no way to disable autocomplete on enter in the script editor.
And just to be absolutely clear: I want to use autocomplete. We have tab and enter for autocomplete. I want to only use tab for autocomplete, and keep enter for creating new-lines only. I am aware of the setting for disabling autocomplete, but I want to keep autocomplete, just not for enter.

For example, if I type else, the autocomplete comes up with ElapsedTime() as autocomplete, and then pressing enter to go onto a new line causes it to replace else with ElapsedTime()
(which is deprecated anyway).
I want to be able to go onto a new line by pressing enter without having it autofill. We have tab for autofilling, there should be an option to disable autocomplete on enter.

Just to be clear, it’s not just else that’s the problem, as seen in the below video.

6 Likes

there is.

1 Like

hm… i see, well, if you type else and want to go to other line, only press spacebar and then enter, if you wanna disable the autocomplete, EVERYTHING will be manually, now if other words come with ElapsedTime(), i recommend you to restart the studio or uninstall and install again.

My point is I don’t want to press spacebar then enter, just want to press enter, and only autocomplete on tab.

I don’t want to disable autocomplete. I want to disable autocomplete on enter.
Currently you can autocomplete two ways:

  • Pressing Tab.
  • Pressing Enter.

It just so also happens that Enter is used to go onto a new line. I want to disable autocomplete on enter, not disable autocomplete. We have tab, don’t need another key to do the same thing which should be doing a different thing anyway (going onto a new line).

2 Likes

Oh man, if you uninstalled and installed again and this error still happen, i dont know how to fix it.

try removing all studios pastes from your computer AFTER YOU UNINSTALL, hope it work!

Hey @tukars - this sounds like a feature request. Maybe you could post here? Feature Requests - Developer Forum | Roblox

Are you still having this problem?

2 Likes

I tried making this as a feature request but when I went to the category it automatically put it as a bug report - I am still having this issue, yes.

1 Like

This is incredibly annoying. Why not add an option in settings “Use Enter for autofill”?

2 Likes

i love how people always answer with the exact thing you say DOESNT work.

I know I’m late but an easier way to escape the autocomplete prompt is by pressing the Escape, Control, or Alt keys. I completely understand your point, however. What Studio needs is a way to edit your autocomplete keybinds. I just went down a rabbit hole trying to find alternative ways to navigate through the autocomplete menu and nope, there’s nothing but the good 'ol arrow keys, which leaves me with two options:

I continue typing the word until autocomplete selects what I want,
or,
I leave the home row for the arrow keys.

Which would be fine, but neither option is enjoyable after the millionth time and that wasted time adds up. It’s not laziness that brought @tukars and I here, but a lack of efficiency.

What’s weird is the fact that Studio has a keybind menu with a decent amount of options. But it doesn’t even have a whisper of autocomplete, which is hilariously frustrating.

Giving us autocomplete keybind access would solve both problems, allowing @tukars the ability to unbind enter from autocompletion and allowing myself to rebind downward selection to something like Shift + Tab.

It’s a simple solution to an odd problem, I’m not even sure why we have it in the first place. I would really appreciate it if the Roblox Team at least got back to me on why autocomplete doesn’t appear in the keybind menu.

2 Likes

I do this and it’s annoying because I gotta reach all the way up there.

1 Like