Not able to change the language of Roblox Studio

This bug has occurred from the Chinese localization took place in Studio, however there are only few words were translated before which were not annoying to me so I did not treat it as a problem.
But today, most of the words in Studio were translated into Chinese. Because of the language difference between China and Hong Kong, I cannot understand some of the words in Studio so I decided to change the language back to English and I found that there is no any buttons in Studio that can change the language, the language settings in Roblox website was English already but this doesn’t help.

Here is my settings in Roblox:
image

Roblox version: 0.387.0.306142
image

System spec: Lenovo Windows 7 PC (64 bit), Pentium® Dual-Core CPU E5700@3.00GHz

6 Likes

This topic was automatically closed after 1 minute. New replies are no longer allowed.

What language is Windows in? Does changing that affect Studio?

My Windows is in Traditional Chinese.

I never tried changing the language in Windows to check if it works because I still using Chinese for other softwares.

We recently shipped an update that attempts to localize Studio in your system locale. We are planning to also ship a built-in language changer in Studio settings so that you don’t need to change your whole system locale to adjust the way Studio is localized, but this is not yet ready to ship.

In the mean-time, we suggest that you set your system locale to English while you have to use Studio.

Alternatively, the FFlagStudioEnableLanguagePreference2 flag guards the built-in language changer feature (set to true), but we do not recommend overriding flags as it can create technical instabilities. Use at your own risk.

1 Like

Thanks for replying, hope the new update will be roll out as quick as possible so I can change my studio back to English as it is kinda annoying sometimes when I found something in the studio.

Can you also notice me here when it is rolled out so I can check if it works for me.

This issue should now be resolved in Studio version 0. 388. 0. 307917. You can find the language setting in Studio settings and flip it to English, then restart Studio. Could you let me know if that works for you?

Yes, it works. Thanks a lot for the update!

1 Like