NPC only animating in studio, not in game

The NPC isn’t animating in game, and only in studio; therefore, I want to achieve making it animate in Roblox game as well.

NPC is animating correctly in studio, without any problems, but all the sudden it wouldn’t in the game itself (as in Roblox Player Application).

I put this script inside the Character NPC model:

local Character = script.Parent

local Head = Character.Head
local Humanoid = Character.Humanoid

local Dance = Humanoid:LoadAnimation(script.Animation)

Dance:Play()

^ And yes, obviously I put the animation inside the script so please don’t ask if I put it in the script.

I’ve tried looking for solutions but I couldn’t have find anywhere.

I don’t know if I am doing anything wrong. This is a Server Script so the animation should be shown to everyone. The Developer Website told to use Server Scripts genuinely with NPCs, therefore I listened.

I want to see what mistake I have made, because this has never happened to me before…

Thank you!

1 Like

You should probably make an attempt at debugging.

Simply saying it won’t work in an actual roblox game but in studio it will isn’t helpful. If you try some simple printing, that can go a long way.

I just found out. All of my scripts are printing “Hello World!” and I have never assigned them to. None of the other scripts aren’t even working. Is there something wrong with my studio?

The code in all of the scripts are different from print("Hello World!") and all of it’s printing that…

Are they getting disabled or even destroyed at runtime perhaps?

I don’t think they are not getting disabled, but what do you mean by runtime?

Like while the script is running

Everything works fine in studio but every single script is just printing hello world during roblox player.

I think the scripts are running because all of them are printing hello world.

I have 5 scripts in the game and there is 5 “hello world” in the server log.

There don’t appear to be any errors with the script, so here’s all I can think of: If your game is owned by a group, the problem likely lies with the animation ownership. Make sure to upload the animation to the group instead of your profile.

2 Likes

Have you looked at the top? Every script is being recoded as print("Hello World!") in the Roblox Player but not the studio.

Have you tried publishing the game?

Yes, I applied edits. I reverted. I published. Still does not work, so I’ll be filing a bug report, since I have already talked this out with someone else to confirm I should file a bug report.

Maybe you should try to reset your roblox studio.

I already did. I already reinstalled it.