Object generates in Studio/Mobile play but not PC


I have an interesting problem. When player clicks the ‘Yes’ button in the pop-up GUI, their house should appear. It’s been working for over a year, and continues to work in Studio and Mobile. However, when playing it on the site with a computer it no longer is. No output errors, and I can still get a print out of the position of where the house is suppose to be. I don’t have any mobile/platform-specific scripts that would interrupt this, I’m starting to think its a Roblox quirk.

Screenshots in Studio, confirmation GUI:

Confirmation, House generated, note the sign displays the house owner’s name:

Output from Studio:

And then this is what happens when attempting to play on the website:

As you can see from the sign, there should be a house, there’s even Position coordinates for the house, but there is no House.

And lastly a screenshot from playing the game on the Mobile device (Samsung Galaxy S6) where the house does generate:

I’ve tried this from both my desktop and laptop, and both continue to work in Studio, but not when playing on the site. I’m confused as to how this could happen now, when as recently as a week ago, there were no problems, and it continues to work properly on Mobile.

Not sure how much it’d help, but here’s the script that fires when the ‘Yes’ button is selected in the Gui:

local HasPlot = Player.Inventory.HasPlot
local CurrentPlot = Player.CurrentHouseDataSession.CurrentPlot
local Plots = game.Workspace:FindFirstChild("Plots")
local HasPlot = Player.Inventory.HasPlot
local PlayerStuff = Plots[CurrentPlot.Value].PlayerStuff
local PlotName = Plots[CurrentPlot.Value]

local Fence = game.ReplicatedStorage.House[CurrentPlot.Value].Fence

if FenceActive.Value == true then local ThingClone = Fence:Clone() ThingClone.Parent = PlayerStuff ThingClone:GetChildren() print('House Position ') print(ThingClone.Position) end

Game Link: Magic World [reLAUNCH ALPHA] - Roblox (walk up to a spot to Rental spot to claim it, Menus - Build for House options, first time players have enough coins to purchase the starter House)

Any insights into what might be causing this is much appreciated. Thanks! :slight_smile:

1 Like

Okay, so I don’t know much but try a repeat wait() until function. If that doesn’t help, try making a RemoteEvent then clone the object.

1 Like

Hi! Thanks for commenting! It already fires as an event to clone the item from Replicated Storage to the Workspace. :slight_smile: I get the outputs that its successfully cloned…but as you can see from the screenshots, no house. :frowning:

I’m very confused as to why it works on Mobile/Studio…but not a desktop. :laughing: I’m ready to blame Roblox at this point…

Try using debugs. Maybe it will help. DM me if possible.

1 Like

Quick question, is your house made of normal parts?

1 Like

The house is made up of parts and meshes. Players can choose how many add-ons they want (kitchen, bedroom, second floor, etc.) but they all start with the base house model.

excuse me asking but when you tested in studio did you check server and client views?

1 Like

Do you have streaming enabled on?

Can you post your code or at least the receiving end of it?

The sign changes in the PC photo, so this is likely a loading issue.

1 Like

Hi, yes, both views were checked.

Streaming enabled is turned on. I posted the code that generates the house at the end of the first post. I’m puzzled as to why it works fine on Mobile, but not PC.

I notice in your code that you aren’t using any :WaitForChild()s. With streaming enabled on, the parts might not be loaded in for PC simply because the PC might be slow. Comparatively, the mobile device might be faster or need to have more parts loaded in so it works.

Though, I’m kinda iffy on that as being a reason. Though do try to use more WaitForChild’s on client when using StreamingEnabled as some parts might not be loaded in for the client.


Hey! Thanks for the response. I added the WaitForChild()s, no difference. =/

Anyone else have any suggestions? :slight_smile: If so, they are much appreciated.
Confirmed it doesn’t work on other Windows laptops, or Macbooks, still just Mobile and Studio.

Checking in again to see if anyone else has any suggestions to try. :slight_smile:

What is the FenceActive value?

Sorry, must’ve cut that part out, its a BoolValue, the part missing is the line of code where FenceActive is true. :slight_smile: I can add it back in. The Fence, House, everything else does generate as noted by the code print out that shows the position, it just only appears in Studio and Mobile, not Computer.

When playing on Mobile, were others in the game at the time?

Yep, on Mobile it worked if it was solo or with other players.

This looks like a cache issue. If you’re using any Unions, Meshes, etc in the house you should go to %temp% and delete the Roblox folder. This will clear the Roblox cache which contains cached asset requests such as textures, sounds, mesh, and union data. That does mean a lot of content has to be redownloaded but this usually doesn’t take long.

(Fun fact: It’s possible to extract contents from cached union data such as the separated version of the union. Even script sources are included!)

Thanks for the response! I don’t think this would be a cache thing, as it affects all users who have tried this from their computer/laptop. I would assume this would require every user to delete their temp folders frequently due to all the games that use meshes, unions, etc. I’ve had multiple people try this on their home computers, including those who don’t play Roblox often and shouldn’t have a cache problem. =/