Object's CFrame isn't changing despite it being told to?

I’ve tried several methods for making this work, none of worked so far.
I’m trying to make an object move to the Player’s lookVector, however it doesn’t even change it’s Position.
Script (Local Script):

local Player = game.Players.LocalPlayer
local Character = Player.Character or Player.CharacterAdded:Wait()
local GUI = game.ReplicatedStorage.SapperGUI
local WoodWall = game.ReplicatedStorage.WoodWall

	local GUIClone = GUI:Clone()
	GUIClone.Parent = Player.PlayerGui
	local WoodWallClone = WoodWall:Clone()

	WoodWallClone.Parent = game.Workspace
	WoodWallClone["1"].Transparency = 0.5
	WoodWallClone["1"].CanCollide = false
	WoodWallClone["2"].Transparency = 0.5
	WoodWallClone["2"].CanCollide = false
	WoodWallClone["3"].Transparency = 0.5
	WoodWallClone["3"].CanCollide = false
	WoodWallClone["4"].Transparency = 0.5
	WoodWallClone["4"].CanCollide = false
	WoodWallClone["5"].Transparency = 0.5
	WoodWallClone["5"].CanCollide = false
	WoodWallClone["6"].Transparency = 0.5
	WoodWallClone["6"].CanCollide = false
	WoodWallClone["7"].Transparency = 0.5
	WoodWallClone["7"].CanCollide = false
	local HumanoidRootPart = Character:FindFirstChild("HumanoidRootPart")
	local HumanoidRootPartCFrame = HumanoidRootPart.CFrame
	while script.Parent.Equipped == true do
		WoodWallClone:MoveTo(HumanoidRootPartCFrame * HumanoidRootPartCFrame.LookVector*5)


This is in a tool, and there are 0 errors. I’m really just confused.

Try using the PVInstance:PivotTo function, you can use it to move the instance using a CFrame.

WoodWallClone:PivotTo(HumanoidRootPartCFrame + HumanoidRootPartCFrame.LookVector*5)

That seems to be fixing the issue, but shouldn’t the object always be changing the CFrame since it’s in a while loop?