Odd behaivor with custom rig animations

Recently while working on my game i ran into an issue, after animating one of of many custom rigs for my enemies, i noticed the animation would only play in studio, and when i animated another it didnt play neither in studio nor in-game


This animation just doesn’t play anywhere , the code is very simple, and according to the GetPlayingAnimationTracks the animation really is playing as it prints “Walk” witch is the animation that moves the tank

Thing i’ve already tried:

  • Double checking the ids
  • Making sure the animation is uploaded to the game’s group
  • Re-publishing the animation as a different asset
  • Loading the animation on both AnimationController and Animator
  • Removing the :AdjustSpeed()
  • Setting Walk.Looped = true in the script before playing the animation
  • Add a Delay before starting the animation
  • Debugging every 1 second to check if the animations are still playing according to the game

How is the tank’s movement handled?

1 Like

Wdym? how i move the tank? well i just tween the primary part on the client, the actual enemy is a block on the server the tank model is just for the client to see its all visual, and just to make it clear, i have other custom rigs with fully working animations and movement, its just the last 2 i’ve made

Did you try doing Walk.Looped = true
Usually when I upload animations they don’t loop even if I enabled it in the animation editor.

1 Like

Good idea, but unfortunantlly it didn’t work

At what point do you play the animation when the tank spawns?
I’ve ran into problems like this by trying to play the animation on an invisible rig and making it visible when needed.

1 Like

As soon as it spawns, debug confirms that

Have you tried adding a delay?

1 Like

I tried just now, it did not work, i also tried printing :GetPlayingAnimationTracks() every second, it keeps saying the walk animation is playing.

Finally found the solution to this problem, apparentlly the new graph animationsm bugged my animation , and i had no idea because in the animation editor it looked fine, i cleaned the animation saves of the rig and made a new one without touching the graph animationsm, and now it works.