"Oldschool" climb animation does not have correct animation names, causing developer code to break

Reproduction Steps
Currently, as of 4/26/22, the “Oldschool” climb animation has an incorrectly named animation. All catalog animations have an animation named “ClimbAnim” inside of them. However, the “oldschool” climb animation is named “climb”. Not only does this go against the standard that all other catalog animations follow, but it also breaks developer code that relies on the standard naming convention of these animations.

Here’s what most catalog animations have their name set to:

Here’s what the “oldschool” climb animation has its name set to:

Expected Behavior
It is expected that the “oldschool” climb animation would follow the standard naming convention for its internal animation instances that all other catalog animations follow

Actual Behavior
The “oldschool” climb animation has a unique animation instance name, resulting in developer code breaking if it relies on the catalog naming conventions.


Issue Area: Catalog Assets
Issue Type: Other
Impact: High
Frequency: Constantly
Date First Experienced: 2022-04-26 00:04:00 (-04:00)


It’s worth noting that this isn’t the only case of this happening.

All of the “Oldschool” animations, besides the idle/swim animations, are incorrectly named, and nine of the catalog jump animations are incorrectly named !ID! instead of JumpAnim for some reason.

Because of these inconsistencies, you should use FindFirstChildOfClass if you ever need to access the Animation object in a script. But I know that people might not be aware of this.



This is still a problem as of 6/30/22.

Hey everyone, just working through old threads, it looks like this was fixed! So sorry for the late response here. Gonna close it out.