Opening roblox studio results in freeze even after re-installing

About 1/2 days ago i was working in some files in studio and i went away for a bit and came back noticed all roblox studio windows were frozen for some reason.
Ever since i have tried to re-open studio on any of my files or just studio itself and it kept freezing for some reason.

I have already tried deleting the roblox folder in appdata-local and re-installing studio but that still results in studio freezing for some reason.

I am unable to work in studio for the past 2 days and this is massively affecting my workflow.

So far i was only able to get into studio once but it took a really long time to unfreeze on the login screen and it also took a really long time to get into a new baseplate place.

I have noticed joining games also takes really long.
It takes 60 seconds for the roblox client to show up.

A private message is associated with this bug report

I have managed to solve the issue by updating my chipset drivers, i no longer need help.

Leaving this out here incase someone else experiences this as i could really find any similar cases like this.


Thanks for posting your solution! Also, if this happens again, please keep us posted.