Optimising sky lighting for Voxel


In this scene, I have voxel lighting with colour correction applied on the left, and compatibility lighting with no colour correction applied on the right:

As you can see, the sky is almost completely grey on the left. How do I best restore the brighter colours of Compatibility in this scene for all of the objects, and not just the voxel terrain?

Here’s my lighting and colour correction settings:



Try configuring “Ambient” and “OutdoorAmbient” to colors other than white/black. Also play with Bloom effects and ExposureCompensation.

1 Like

After a long while of experimentation, none of those options work. I guess I’m sticking with Compatibility until there’s a proper solution to this :confused:

1 Like

Wow this Voxel map looks really good and legit! I swear i didn’t realize it was Roblox until a closer look.
Anyways, you could edit the Skybox’s textures in an image editing program. You just get the image you showed us of the comparison, edit the grayed out sky until it looks like the normal one, then apply the exact same settings of image editing to the actual textures of the skybox and it should appear just fine in game.

But it could also be how high up the map is. Depending on how high up the camera is, the sky can change colors. At 3AM (Ironic, i know) if you go very high up in the sky it will turn a bright Lapis Blue color. Weird and annoying glitch for sure. So try and check for that. That glitch also didn’t seem to happen in Legacy shaders.