Output is giving red words for a line of script and cant find answer to it

Hi im new to roblox scripting and a making 2 dice that fall, and while i was running script the output would give red words on my script but i checked everything and couldnt find the problem plz help.

(sorry if this is wrong section)

It’s because You defined the Dice as it own object and your script is

dice1.Dice1 ← this is, it means you’ve defined the dice1 as its part but you use Dice1 by using dice1 as parent
Try this .

local Dices = game.Worskspace.GameParts.Dice

Dices.Dice1.Achored = false

Sorry for the really complex explain.

Anyway This should be in Scripting
Support topic.

Edit: Sorry for my grammar.

1 Like

it says [Worskspace is not a valid member of DataModel “Baseplate”]

Try this:

local dice1 = game.Workspace.GameParts.Dice:FindFirstChild("Dice1")
local dice2 = game.Workspace.GameParts.Dice:FindFirstChild("Dice2")

dice1.Anchored = false
dice2.Anchored = false

Also, this should go to #help-and-feedback:scripting-support


If my solution worked, please mark it as Solution so others know this is solved.