Overhead gui not cloning to player's head

so once again i tried to make some overhead gui script but i decided to test it out first, but the problem is, that the overhead gui won’t be parented under the player’s head at all
adornee property is already perfectly set, but billboard gui won’t get parented under the character’s head and won’t show up perfectly at all
i also tried to watch youtube tutorials on overhead guis, but none of them worked, i also tried to format the code a bit, but still didn’t work, help

		local billboardguiclone = game.ReplicatedStorage.BillboardGui:Clone()
		billboardguiclone.Parent = char.Head
		billboardguiclone.Adornee = char.Head

Is this in a ServerScript or a LocalScript?

it’s a serverscript, under serverscriptservice

Only thing I’d consider checking is calling WaitForChild() if the Head of the Character doesn’t load properly, other than that it seems to work fine for me

        local Head = char:WaitForChild("Head")
		local billboardguiclone = game.ReplicatedStorage.BillboardGui:Clone()
		billboardguiclone.Parent = Head
		billboardguiclone.Adornee = Head

Also try to make sure any of the other Properties within the BillboardGui seems unusual, like if a Frame/ImageLabel's Transparency is 1/Visible is set to false


i tried your solution but it didn’t work, any further help would be appreciated

Double check this, also add prints as well within your script to ensure that everything properly works

i tried prints, but it still prints everything out after the code, although it doesn’t parent it to the player’s head at all
also, the properties are normal, nothing unusual

Last thing I’ll suggest is if there’s any other Scripts that could be overlapping your Gui Cloning script, if that isn’t the case then I’d consider taking a look at this place file here to see what the issue could be

OverheadGuiIssue.rbxl (38.4 KB)

i ran your file but it still didn’t display anything above the player’s head, further help is appreciated

Something’s up with your Studio then, cause it’s definitely working for me without an issue whatsoever

Image from Gyazo

I’d consider reinstalling Studio, maybe even your PC/Laptop as well & check if you have any potential malicious software hidden on it

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.