Parenting a tool doesn't work

Hi, the title explains it all. Basically, after the animation is playing, the tool should remove itself, but I tried with something else other than Destroy() because the holding animation wouldn’t stop. I tried then parenting the tool to Debris or to nil, it didn’t work.

Server Script:
	script.Parent.Parent:WaitForChild("Humanoid").Health = script.Parent.Parent:WaitForChild("Humanoid").Health + 25
	script.Parent = game:GetService("Debris") --or nil
Tool Properties

I was thinking it has to do with can be dropped, but I don’t know.

No errors. Any help here?

Try Humanoid:UnequipTools()
Humanoid:UnequipTools (
I believe this should stop any default “holding” animation, however, if you are using a custom one, you may need to use the :Stop() method of the playing AnimationTrack.

Yes, I know that, but the Anims script is a local script, different than the other server script. And I was wondering if Destroying a tool on local would be working?

Also the UnequipTools wouldn’t work because I want the Vitamins to not be in inventory anymore