Parenting any instance causes a freeze of 0.1 second per instance

I have been having an issue for the past 4 years where a specific place in studio on team create on a specific device suffers from massive freezing issues and i cant get it resolved.

Everytime an instance is parented to workspace, my studio freezes in both runtime and regular studio to the point where scripts stop executing.
If i try to insert a big script it will disconnect me from team create and corrupt my place file because the changes were not saved.

I have tried wiping the cache and re-installing studio but it just does not go away.
I have no issues on my laptop with the place.


I also took a look at my log files and noticed some type of http request was taking 7400ms everytime it was calling

The affected place is

Expected behavior

studio not to freeze and prevent scripts from running.

A private message is associated with this bug report


Can you get a more detailed microprofiler report using these instructions?


I came up with a solution that made me not lose any saved data in roblox by copy and pasting all of my roblox folders on my entire desktop with the ones from my laptop and it resolved the issue.

1 Like

Please do not mark this as a solution, solving your specific case is not solving the bug, no action of the user should be required at all and just because copying out files worked for you, it will not work for any users experiencing a similar issue yet are without a seperate device!

1 Like

Hello, we are currently going through unresolved bug reports.

We unfortunately cannot do anything about this without a repro case, and so we consider this resolved until then.