Part does not fall even without anchored

Hi! I mention my problem that I have while scripting, it should be noted that I am new to scripts.

What do you want to achieve? By clicking the button, drop a box.

What is the problem? Clicking the button creates the box, but it does not drop yet without anchored.

What solutions have you tried so far? I tried to ungroup it, redo the script, restart roblox studio, remove and put the anchored but nothing.

I made a script where when clicking a button, a box falls, something very simple but what happens is that when you click the button, the box is created but does not fall, here is the script:

local click = script.Parent
local cubo = script.Parent.Parent.Parent.Cubo

	local clon = cubo:Clone()
	clon.Parent = cubo.Parent
	clon.Transparency = 0
	clon.CanCollide = true
	clon.Anchored = false

It is probably a very obvious error of mine, but I have not found a solution yet, and no error appears in the output. (I am using a translator)!

Try adding prints in the function and see if it shows up in the output.

Also, a alternative to Cubo.Parent can be game.Workspace

1 Like

dont add the clon.Anchored = false, make sure the clone part is un-anchored.

1 Like

Unanchor “Cubo” and put it in serverstorage then clone it from their and set the position to where Cubo is in the second picture.

1 Like