Part isn't welded, but acts like it is

I’m trying to make a simple suspension setup for a car.

The suspension setup is as follows: A dark grey bar connects to the chassis. Yellow blocks underneath it act as the axles, and have Prismatic, Spring, and Hinge constraints between it and the grey bar.

For some reason, the rear axles (yellow bricks) are able to move, but the front axles aren’t. Both should be able to.

There are no welds or constraints that I can see that could be affecting this, and all settings on all the constraints are defaulted. It isn’t anchored either. Also, I have tried simply copying the rear suspension setup to move it to the front, but the new copy is behaving the exact same way. This is the rear of the car. The front, as you can see, isn’t affected by gravity.

I can provide more pictures if necessary.

Could you send the model as a file so we can take a look?

rc_car.rbxm (7.5 KB)

I’m pretty sure that’s just the way the chassis works, expect it’s backwards. The front wheels should turn while the rear ones are locks straight.

… I’m an idiot. I know exactly what you mean LOL

The hinge probably acts as a weld when it’s together, hence why I used to use 3 layers instead of 2… I’ll try it out. Thanks for helping!

(edit) SOLVED: The hinge only allows movement on its axis, meaning the springs couldn’t function properly.

1 Like