Part lighting glitch

I’ve been experiencing this part glitch when trying to build exo suits, I’m wondering if anyone has any idea of how I fix this and/or if anyone else has been experiencing this. As you can see there are brighter dots on some of the parts, and I’ve tried everything but they wont go away. Any help is appreciated!


What tools are you using to make this, unions, or meshes, or just normal parts?

These are made with unions and simple parts!

Most of the time, unions preserve the colors of their original parts when they bond. Have you tried separating them, and checking the colors of the normal parts to ensure they fit?

All of the unions are negated, and the parts used to negate were the same color. Could it have something to do with the fact of there being dummies nearby? (Just a wild guess)

It also only appears on one side, and only on these builds, no others in the same game.

Wouldn’t think so. Could it have to do with lighting being odd? On a second glance the coloration doesn’t seem to match part shape, so it might be caused by lighting’s interaction w/ the unions. Are the pieces reflective, or transparent at all?

They’re neither transparent nor reflective… I’ve also tried placing these models in a different game but to the same result. I’m personally very confused…

Could you try to reproduce the same issue on a blank baseplate?

Unfortunately this is a side effect of Humanoid shadows.


Oh I see. Thank you so much, now I finally understand what’s going on! And thanks to the rest of you for helping!


Is this issue only on the Voxel engine?

1 Like

This issue predates Voxel lighting and likely occurs on both.

@Caayn Can you provide some details about your characters? Are they made of unions or meshes? How many polygons? Do they have textures applied?


The characters are simple block rigs created using the Rig Builder plugin! Some of them do have parts with changed colors, but some of them are just clean rigs with the same problem.

1 Like

If you’re willing, can you message me a model of one of your suits affected by this issue? I’d like to see if I can figure out the conditions that cause this and try to find a workaround since I’ve seen this issue come up more than once, but I haven’t been able to replicate it myself.

With pleasure!

Edit: Laptop charger is broken so I cant use my laptop, we’ll have to wait until Monday.

1 Like