Particle Effects are not visible

Particle Effects are not visible within Studio view nor Client or Server view.

While inserting a ParticleEmitter, no particle effects are visible.
This started happening with the new studio overhaul update.

The image above shows a default, freshly inserted ParticleEmitter with no effects.
My studio is settings are mostly max and everything is correct.


I found something interesting, Changing the Studio setting Rendering, Editor Quality Level to 15 instead of 21 makes some particle effects to show. Anything above level 15 causes invisible particle effects.

ANSWER: Apparently, Roblox’s beta features completely break certain rendering aspects such as particles. Disabling beta features resolved the issue.

1 Like