Particle emitter not working in transparent union

Hello! I’m trying to make an aquarium but I’ve ran to a problem. The particles from a particle emitter aren’t visible.
Here is what it looks like:
robloxapp-20210502-1136223.wmv (1.1 MB)
Please help, thanks!

It looks like you are using the Glass material, which has some custom properties that have rendering issues with terrain water and particles for example.

Your only option at the moment is to go with something like SmoothPlastic, if you raise the Reflectance property you should be fine until they fix it.

1 Like