Particle System Completely Disabled

Reproduction Steps

Call :Emit() on particles within the newest studio update or simply enable an emitter parented to an object in workspace.

Expected Behavior

Particles should be visually displayed in studio.

Actual Behavior

All ParticleEmitters in the latest studio update are not enabling whatsoever or emitting when :Emit() is called.

Issue Area: Studio
Issue Type: Display
Impact: High
Frequency: Constantly
Date First Experienced: 2022-10-12 14:10:00 (-04:00)
Date Last Experienced: 2022-10-12 00:10:00 (-04:00)


I don’t know why this post doesn’t have more interactions or any remark from a Roblox staff member. This is a bug that interferes significantly with development.


The textures themselves are working and loading perfectly fine, so this is definitely a problem with Particle Emitters themselves. This is likely a huge issue for anybody working with any kind of effects, myself included. This only occurred during the latest studio update, so I would assume some backend stuff was configured regarding particles. Hopefully once enough people start talking about it, Roblox will take notice.

1 Like

Just want to bump this report as it’s a big issue for my studio at the moment.
I personally can’t replicate the issue, however a VFX artist on my team is unable to see particles rendered within their workspace which is impacting development.


Hey, temporary fix but what worked for me was to set my Graphics Edit Quality Level to 15 or less. This will disable Anti-Aliasing though so you will notice your game looking a bit more pixelated.

1 Like

I’ve been starting to notice this issue when testing my tropical cyclone system and only just now starting to realize it’s occurring in every place and not just the one I tested it in.

Maybe that’s why particles aren’t appearing. Anti-Aliasing must be doing something that just screws up particle rendering.

Hopefully they fix it soon, can’t see any particles anymore

i cant see any of my particles in studio after the new update, massive issue

1 Like

That’s what I would assume, but it’s never been an issue before so unless they made changes to Anti-Aliasing I’m not sure

1 Like

Cant see any as well!!!

1 Like

I’m not sure if this was fixed or not but it’s working for me on Windows 11.

Granted I’m not using a custom texture for the particle, I just inserted a ParticleEmitter into a random part.

This does seem to temporarily fix it in normal workspace but if you run test or play test it’s still completely disabled.

That’s what I was trying to say. They must have made changes to AA and not realizing it screwed up how particles are rendered. I hope they fix it soon.

Can confirm particles are completely munted.

Very major issue, hopefully this is fixed soon. If anyone needs a quick fix, lower your graphics settings and particles will reappear normally (albeit at a lower quality).

This has been occurring for a while for one of my friends, updating his gpu drivers temporarily fixed the issue, but now the issue has returned

time to bump this since I have witnessed some… interesting activity to say the least
number sequences & values are broken, images do not load in correctly at certain angles

maybe some of the engineers tried to remake source engine’s particle system inside the roblox engine, i must say they did a good job at replicating it

1 Like

Yep, this really confused me. All particles not working on my studio, impossible to edit particles now :frowning:

got an update to this
this bug starts appearing only on graphics quality set to 8 and above

Same here, I can’t see any particles. Fix this soon it breaks lots of developers from working.

1 Like