ParticleEmitter Size Property Number Sequence has Max of 1

Reproduction Steps
set a particle emitter Number Sequence and you can only set it to maximum of 1

Expected Behavior
previously the maximum was 10, I expect at least that to happen.

Actual Behavior
its just maximum 1 now, which is not usable for most applications.

We should be able to set any number range we want, even above 10, or maybe have a base number and the the Number Sequence represent a percentage of total such as Transparency.

Workaround
nope

Issue Area: Studio
Issue Type: Other
Impact: Very High
Frequency: Constantly
Date First Experienced: 2021-10-12 00:10:00 (-07:00)

14 Likes

Ive also experienced this issue today, hopefully it gets fixed soon, as it is really annoying.

2 Likes

Please increase the maximum limit as well. Thanks!

A better idea than increasing limit is what I suggest above, elaborated here:

Size should have 2 properties: MaximumSize, and SizeScale

MaximumSize would be the maximum size you want to base your scaling on.

SizeScale would be a NumberSequence from 0 to 1 that represents a percentage scaling over time based on the MaximumSize

2 Likes

You can use script to increase particle size to as much as you want

2 Likes

True, but this is not practical in many workflows while designing the particle visually. Testing over and over again is time consuming.

I’m working on a fix ASAP, apologies!

2 Likes

This should now be fixed (unfortunately that means the new particle squash feature won’t be re-enabled until next week).

3 Likes

It’s limited to stop troll viruses and to much makes your computer catch on fire.

I don’t think that’s the reason for the limit. You can change the size above the studio limit via scripts (I think).

1 Like

I agree that having the limit raised to like very big size would makes particle design much better and more conventional.

If this issue reoccurs, please create a new topic for us to look into. Thanks!