Particles don't disappear when not rendered

When an object emitting particles moves off the screen, the particles stop rendering. But as soon as the object enters the screen again, particles appear at the same point they stopped being rendered. Basically particles that should have disappeared a while ago suddenly reappear. Here’s a repro: ParticleRenderBug.rbxl (11.4 KB) (11.4 KB) Just position your screen so the orb will move off the screen, as soon as it enters it again the particles will appear.


That’s by design.

The particles reappear after an indefinite amount of time though, don’t they? If a particle has a lifetime of 3 seconds it shouldn’t reappear some 30 seconds after the object returns to the screen.

1 Like

They don’t reappear actually, any processing for the particle system is halted, time freezes.

1 Like

Yes, but they reappear visually. I know it’s strictly a visual side-effect of how the particle system works but it causes some annoying visuals, when a projectile with a particle trail launched offscreen reappears, it the particle trail where it was a couple seconds ago shows again. Couldn’t it at the very least detect if enough time has passed since it last was visible for the lifetime to expire?

Edit: I tried to change the place file to display what I mean more accurately.

1 Like

I’m planning to release an update for particles (soon™) with a couple of goodies anyways, so I’ll see what I can do.


I don’t see why this is by design?
If a particle is enabled = false and you pan your camera away from it, it should disappear, not wait till the camera comes back into frame of it 20 minutes later to disappear.

Still waiting for a fix to this… but I’m assuming there will never be because this is by design.


This is definitely something that needs to be addressed. Particles get hung in midair all the time and it’s quite weird to say the least. I feel like having useless particles behind your character could have some problems, but I’m not entirely sure.


I hope this is changed soon. When a player looks away from particles, I don’t want them to see an explosion of them when they look back towards them. It’s hurting progress on a new game of mine.


We should at least have the option to toggle this behavior.

This really hurts performance. For example, if lots of explosion particles are emitted behind the player they stack up over time and unload as soon as the player turns around. It also just doesn’t make sense visually.


Does the same thing for animations. Sometimes the animations will speed up and will cause lag on lower-end devices once you turn around.

please fix this bug , it is lagging my game real bad

1 Like

This “intentional design” creates a lot of performance issues since the particles are still being drawn off screen even if the player cant see them.

Its also annoying since it appears these “frozen particles” don’t do any calculation to detect if they should actually still be there when visible on the viewport again.

Many games that implement a “freeze time” system store a small timestamp of when they were last rendered onto the screen, then, when they next get rendered, it allows the engine to calculate what needs to be done with the difference of time. Roblox doesn’t do this.

1 Like

@iam13robloxexactly @metatablecatmaid this is a solved bug report, please file a feature request