Pathfinding link isn't working

Reproduction Steps

  1. Create a pathfinding link
  2. Try to change Attachment0, Attachment1, IsBidirectional, or Label

Expected Behavior
Properties Attachment0, Attachment1, IsBidirectional, and Label should change when I click on them and I interact with them.

Actual Behavior
When I try to set them, it’s not working. It won’t do anything.


Issue Area: Studio
Issue Type: Other
Impact: Very High
Frequency: Constant
Date First Experienced: 2022-6-2 00:11:00 (+01:00)
Date Last Experienced: 2022-6-2 00:12:00 (+01:00)


Is this in TeamCreate?
Have you tried saving and exiting the place then restarting Studio?

Yes, it is in TeamCreate(You can see it in the video), and yes I have tried to restart the studio.

Well, back to basics. Have you uninstalled and reinstalled Studio?

No but I asked my other 2 friends to test it, and it wasn’t working for’em. By the way, I disabled all my plugins when I was testing it.

Hi, This feature is not enabled yet and will be released as a beta in the near future.


Thanks for letting me know. I’m looking forward to seeing it in my game!

I need some help. Every time I insert a part into studio, I get an error that says, “Pathfinding link functionality is not enabled.” Could you please help me?

i mean, maybe read the error message. It says “Pathfinding link functionality is not enabled.” because it’s not out yet. wait a few months/weeks and it’ll be out

1 Like

dude its an issue stopping us from making our games. how do we fix it? i put down a part and i cant move it because of that stupid error

Do you have any PathfindingLinks inside of your game ?

@BoneCrusher132435 @Verse_NOVA Recommended not to use PathfindingLink in your game before it’s officially in beta.

You can use this to remove all PathFindingLinks from your game:

for _, object in ipairs(game:GetDescendants()) do
   if object:IsA("PathfindingLink") then

@watIsInTheName If people are not yet meant to use these objects, please have your team disable them from being inserted via the quick insert menu. This is a poor user experience.


i dont think i do since im making guns and not npcs currently. Its not even issues with pathfinding, i am having issues with dragging parts in my workspace. I still get that same error for some reason.

my studio actually doesnt even recongnize the object type “PathFindingLink” as an object

Should be “PathfindingLink” (note the casing, no uppercase F)

Here is the error I have been experiencing. I have looked, and I was unable to find any pathfinding links. It only occurs when I insert a part into studio, but it happens every time.

They are enabled now as a beta.


This topic was automatically closed after 17 hours. New replies are no longer allowed.