Pathfinding literally does not work

Okay, I don’t think I need to show pictures because of the nature of this problem, but I can answer any questions.

The pathfinding system literally does not work. I have tried everything to assess at least the core of the problem, but every attempt has given me even more questions than answers.

Here’s everything I have tried.

  • Used multiple pathfinding scripts in the toolbox
  • Copy pasting pathfinding from another game where it had worked
  • Just straight up tried whole models from the toolbox

All my code in the script worked up until it was told to start pathfinding. No, it’s not anchored. No, the ownership of the network has been set to nil. I can’t find any other solutions. I’ve even tried to tinker with the game settings. My only possible theory is that the game has too much going on for the pathfinding service to work, but even then I’m not sure if that’s how pathfinding even works.

Help would be greatly appreciated.

1 Like

Can you show the code and the explorer where the script is?

The pathfinding only do some calculs and setup waypoints from the Start location to the End location using your given settings.

The character isn’t moving automaticaly, you have to move it by yourself using Humanoid:MoveTo(WaypointChoosen.Position).

Please consider showing your scripts / code when asking for help, nobody are able to help you correctly without it.

Kindly crosscheck with this code

I’ve experienced issues with Roblox being unable to generate a navmesh when there is complicated geometry on the magnitude of tens of thousands of studs.

If this is the issue you’re facing try to find the “Show NavMesh” option in Studio > Studio Settings. There should be very obvious blue everywhere if it is working. Anywhere that doesn’t have it failed to generate.

If it doesn’t appear I’d recommend searching for parts that are extremely far away, or re-doing sections of your map that are not working.

Sorry for the long reply, I had to go on a camping trip.
Anyways, I used an API to help me with the pathfinding, so the actual pathfinding is kind of out of control. Regardless, it doesn’t change the fact that the rest of the AI scripts that aren’t dependent on said API still don’t work. Here’s the API if you want to know about it.

Let me know if you still want to see my code anyway.

Continuing from that last reply, I did find that the NavMesh didn’t show up. That may be the root of the problem, so I’ll try to find a solution to close this thread.

1 Like

Okay, I found out that some parts I’ve put were waaaay too far away for the pathfinding to work. I’ll just delete some of them.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.