PathfindingService seemingly internally broken

So for several months, I recall having no issues in regards to my AI’s pathfinding performance.

Recently though upon testing, I’ve found it’s been doing this alot.

Based on tests, it would seem that something is wrong in regards to PathfindingService based on how the path nodes are rendering, but this would not make sense as the AI worked perfect several months back, and I changed nothing.

Suddenly, the AI has been doing this consistently both in the old place and the new place, the one I am updating.

I used the SimplePath module, and it’s been working great. From the debugging I have done, it says that the path is computing properly, but the nodes rendered would not seem to reflect that state.

Really confused, would appreciate anything I could try here.

It almost seems as if PathfindingService is anticipating for the AI to jump over the railing, even though I explicitly set its CanJump parameter to false in the path object. So this also would lead to an engine inconsistency.

Thank you all.

1 Like

can we have the code so we can properly examine whats causing the issue?

1 Like

I use the SimplePath module, which has not been changed over the course of the past few months.

I do not believe this to be an issue regarding the code, as it worked perfectly previously.

oh well then its probably an engine bug as i am sure you know roblox just updated. submit a request in #bug-reports:engine-bugs or just wait for someone else.

1 Like

there are too many reports about pathfinding being broken, the best thing i can think of is making a pathfinding thing yourself

1 Like

dead inside.

my brain, unfortunately, is not big enough for such a task

1 Like