Pause "On Unhandled Exceptions" stopped working (Intuitive Debugger)

Reproduction Steps

1) Set in scripts to pause “On Unhandled Exceptions” (if not already set) and close Studio:
image

  1. Open Studio and create a LocalScript
  2. Put this to force an error:
a = {}
print(a.b+1)
  1. Run

Expected Behavior

The debugger should stop at the error line

Actual Behavior

The debugger does not stop at the error line. This started to happen after this:

Workaround

Manually select “On All Exceptions” and then click “On Unhandled Exception” again.

  • But if I close Studio and open it again and repeat the process, the problem reoccurs.

Issue Area: Studio
Issue Type: Other
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2023-01-23 00:01:00 (-03:00)

2 Likes

As I reported here (ABSURDLY SLOW DEBUG (Intuitive Debugger) - #4 by rogeriodec_games), Roblox has again allowed to disable the Intuitive Debugger.
But the problem reported in this thread remains, so I’ll keep it open.

I am experiencing this as well. To add context to the level of impact:

We rely on this debugger break to catch problems during development. If they get silently buried in output spew, we miss critical problems during regression tests. Please fix this ASAP.

1 Like