Payment Type Selection Error

Page URL: https://www.roblox.com/upgrades/paymentmethods?ap=482
Impact: High
Frequency: Constantly
Date First Experienced: 2021-03-15 00:03:00 (-04:00)
Date Last Experienced:

Reproduction Steps:
User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.90 Safari/537.36
Platform Type: PC
Device Type: Computer

WEB:

  1. Select “Get Premium” on the left navigation bar.
  2. Select any Premium membership and click subscribe now.
  3. Select payment type and click continue.

Error message “An error has occurred.” However, this message does not show when you select the option of Roblox gift card.

IOS:

  1. Select “More” from navigation bar.
  2. Select Premium, choose membership, and click subscribe now.
  3. Click on green purchase button.

Error message “An error occurred during this purchase.”

Expected Behavior:
Upon completing steps, the website should allow for the selected payment type to be used to make a purchase.

Actual Behavior:
Error with selecting payment type for premium purchase. After selecting payment method and clicking continue, the websites gives an error message and will not continue with the purchase. The only payment method that can be selected is Roblox Gift Card. If you select another payment method and click continue it shows “An error has occurred”. It is unknown if this is an error on the user end or not.

This also was replicated on the IOS application.

29 Likes

I’ve been having this problem ever since the beginning of April. I have made many accounts over the years, and I can’t buy premium on a single one because I get this same error. This issue seriously needs fixing. Imagine how much potential money roblox has lost because of this.

13 Likes

I’m also experiencing this error, and it’s only happening for specific accounts.

6 Likes

Yeah I’ve managed to get it to work, but only with two really old accounts that I haven’t used in well over 5+ years. There doesn’t seem to be any pattern to what will and won’t work either.

3 Likes

Any update on this? I think this is a pretty breaking bug, and it now affects buying Robux, which prevents users from buying Robux altogether, and prevents Roblox from making a lot of profit. Is there any workaround?

The ErrorMsg parameter in the url is “ValidationFail”

1 Like

I’m getting this on an account of mine that is used to hold groups for me. I want to buy a roleset and I’m getting a little bored of how long it’s taking for me to use group fund payouts. However, just like this post, I can’t buy anything except via gift cards (of which I have, unsurprisingly, 0). At first I thought it was due to incognito mode, but I tried using Firefox to do it and I get the same &errorMsg=ValidationFail query string in the URL on all payment methods, except PayPal which has &errorMsg=ResponseErrorOccured (presumably because it isn’t going through XSolla).

This is a bit of a showstopper for me. I’ll either have to wait some amount of days for a group payout to become a viable option (my funds have been stuck in limbo for a while now) or… actually, that’s about it. I can’t buy Robux, so I can’t create shirts to put on sale to fund the account since it costs 10 R$. Bit of a catch-22, eh?

I’m also experiencing this error, and it’s only happening for specific accounts. Any update on this issue eh? It’s been a while since it first came out.

1 Like

This issue is occurring on the company account that we use for marketing and Advertising spend. We’re unable to purchase Robux or Premium with PayPal or via Debit Card.

We’ve had to resort to buying Giftcards and stores have limits on how many you can purchase at a time.

Both iOS and Chrome have the same issue.

1 Like

Hello!

I have looked into this issue using some general knowledge of how I thought the ROBLOX Page might be giving this error and why.

I came to this conclusion…

Maybe it just wants to know that I am active and not a bot?

Here is what I did:

  1. I joined a game
  2. I sent friend requests to people (about 3, none got accepted)
  3. Left the game and went back on the roblox site and went to my TRANSACTIONS page
  4. Right clicked the Buy Robux button and opened in New Tab
  5. No error message what so ever and made my purchase

(I have tested this method via Windows OS, but in regards to the operating system of your device, I believe it is irrelevant being that this method has nothing to do with your OS.)

Note: After I did this method, I am now able to go to the ROBUX page normally with no issues. It is also possible that you need only go to the transactions page and open the Buy Robux button in a new tab, feel free to test this and confirm/deny.

Hopefully this solution will work for others!

5 Likes

Here is what I have come up with: Payment Type Selection Error - #9 by toecurl

2 Likes